HPE BladeSystem Server Blades
cancel
Showing results for 
Search instead for 
Did you mean: 

534FLB boot from SAN Windows 2012 R2, having problems

chuckk281
Trusted Contributor

534FLB boot from SAN Windows 2012 R2, having problems

Esa was having issues:

 

***********

 

 

We are not able to create Windows 2012 R2 boot from SAN Blade server with VC FlexFabric and 534FLB (Broadcom) FCoE adapter.

 

 

When booting up VC SAN boot configured BL460c Gen8 server with 534FLB it found SAN disk at POST BIOS level.

And we can see fabric login to SAN sw as well.

 

When booting to Windows 2012 R2 installation media and insert latest diver for 534FLB no any disk founded.

Not even logged to san anymore!?!??!

 

If installing Windows 2012R2 to local HD and adding 534FLB latest driver it works fine. No problem accessing SAN disk 3par or EVA.

 

VC  4.10

OA 4.11

534FLB firmware form SPP 2014.2 (fcoe 7.8.76, Bootcode 7.8.79)

534FLB Dirver for Windows 2012 R2 7.8.81.0

Brocade 8/24 SW firmware 7.2.1

 

 

554FLB (Emulex) with exactly same configuration works fine.

 

Any tips???

 

**************

 

Info from Lionel:

 

*************

 

 

FYI, this is what I just received from Broadcom support: according to them this is a Windows Server 2012 bug! :

-------------------------------------------------------------------------

“You must inject the drivers into the Windows Server 2012 R2 install image using the MS’s DISM tool – and they need to go into both the WinPE.wim or boot.wim and the actual OS install.wim being used.  You cannot just provide the drivers (via USB or CD/DVD) during installation as shown in your screen captures (above).  This is a Windows 2012/2012R2 OS bug for FCoE boot remote installation.

 

The Win2012 Windows ADK is at http://www.microsoft.com/en-us/download/details.aspx?id=30652.

 

The Win2012 R2 Windows ADK is at http://www.microsoft.com/en-us/download/details.aspx?id=39982.

 

How to use WADK’s DISM tool is at http://technet.microsoft.com/en-us/library/hh824821.aspx, http://technet.microsoft.com/en-us/library/hh825251.aspx, http://technet.microsoft.com/en-us/library/hh825239.aspx.  For an overview of the WinPE versions see http://en.wikipedia.org/wiki/Windows_Preinstallation_Environment.

 

****************

 

And from Troy:

 

************

 

That explains why our Boot from SAN Configuration Guide specifically states to use a Windows 2012 install media with the drivers slipstreamed for Broadcom CNA.

http://h20564.www2.hp.com/bc/docs/support/SupportManual/c01861120/c01861120.pdf

 

************

 

Other comments, suggestions, questions?

 

1 REPLY
marcelkoedijk
Frequent Advisor

Re: 534FLB boot from SAN Windows 2012 R2, having problems

What i known from HP is that there are some problems with 534flb adpters in 2012R2, better choice the 554FLB for R2 enviroments. Please register a call by HP support for this issue.