HPE BladeSystem Server Blades
cancel
Showing results for 
Search instead for 
Did you mean: 

BL460 Gen8 drivers

Delcho Tuhchiev
Frequent Advisor

BL460 Gen8 drivers

Hi,

 

I have RHEL 6 update 2 installed on a bl460c Gen8 server. I have applied latest security updates , and my kernel version is changed from 2.6.32-220 to 2.6.32-220.46. I would like to know what are latest drivers for the bellow listed devices:

 

  1. Emulex 554FLB adapter
  2. HP Smart Array P220i

 

I found that drivers available for RHEL 6 update 2 are prety old (no newer version for this release) and they are build for initial kernel version 2.6.32-220. Please advice what drivers should I use.

 

Thanks

 

 

P.S. This thread has been moevd from ProLiant Servers (ML,DL,SL) to HP BladeSystem Server Blades. -Hp forum moderator

7 REPLIES
Jimmy Vance
HPE Pro

Re: BL460 Gen8 drivers

This link takes you to the driver page for RHEL 6 on the BL460c Gen8

 

http://h20564.www2.hp.com/hpsc/swd/public/readIndex?sp4ts.oid=5177951&swLangOid=8&swEnvOid=4103

 

If you look at the release notes for the hpsa drvier is shows what update version to download for the various kernel levels.

 

The 554FLB driver requires a firmware update on the controller.

 

The firmware update and driver can be found here

 

http://h20564.www2.hp.com/hpsc/swd/public/readIndex?sp4ts.oid=5215387&swLangOid=8&swEnvOid=4103

 

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Delcho Tuhchiev
Frequent Advisor

Re: BL460 Gen8 drivers

Hi,

 

In link that you have provided there is only drivers for RHEL 6 update 4 and 5 which have a totaly different kernel than 6 update 2. So still in same situation no new drivers for RHEL 6 update 2.

Jimmy Vance
HPE Pro

Re: BL460 Gen8 drivers

There is an hpsa driver for U2, but you have to go back to an earlier revision for the NIC at U2.

 

Curios as to where you got 2.6.32-220.46 as the last kernel I see released from Red Hat for U2 is kernel-2.6.32-220.23.1

 

What versions of hpsa and be2net are in 2.6.32-220.46 ? You should be fine with the drivers inclused with the kernel




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Delcho Tuhchiev
Frequent Advisor

Re: BL460 Gen8 drivers

Skernal is exactly 2.6.32-220.46.1 it comes when apply lastest security updates with yum directly from RedHat repos.

According to the drivers i have the following:

 

kmod-hpsa-3.4.2-4.rhel6u2.x86_64.rpm

kmod-be2net-4.6.247.7-1.rhel6u2.x86_64.rpm

 

But both drivers are build against 2.6.32-220.el6 kenel.Perhaps they will work with new one too but I just wander if there is newer versions of drivers or at least SRC RPMs of newer versions....

Jimmy Vance
HPE Pro

Re: BL460 Gen8 drivers

run modinfo on the drivers and check the version, Both drivers should be part of the kernel you installed and should be newer that the rpm's listed

 

 

Figured out why I didn't see the kernel, it is in the extended update support offering. The last general release u2 kernel was what I listed above




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Delcho Tuhchiev
Frequent Advisor

Re: BL460 Gen8 drivers

Unfortunately they are not newer :(

 

]# modinfo hpsa
filename:       /lib/modules/2.6.32-220.46.1.el6.x86_64/kernel/drivers/scsi/hpsa.ko
license:        GPL
version:        2.0.2-3
description:    Driver for HP Smart Array Controller version 2.0.2-3

 

modinfo be2net
filename:       /lib/modules/2.6.32-220.46.1.el6.x86_64/kernel/drivers/net/benet/be2net.ko
license:        GPL
author:         ServerEngines Corporation
description:    ServerEngines BladeEngine 10Gbps NIC Driver 4.0.160r
version:        4.0.160r

Jimmy Vance
HPE Pro

Re: BL460 Gen8 drivers

Is there something wrong with those drivers? Why are you looking for newer versions?  With RH EUS the updates only contain critical security fixes and urgent-priority bug fixes




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!