HPE BladeSystem Server Blades
cancel
Showing results for 
Search instead for 
Did you mean: 

BL460c G6: Unable to upgrade controller P410i

jorgesoto
Occasional Advisor

BL460c G6: Unable to upgrade controller P410i

Hi everyone,

 

I am unable to upgrade my P410i controllers to latest 6.60 firmware using the .scexe file, when ever I run the firmware upgrade it tells no supported controllers are found. however, if I run the Service Pack ISO the controller is upgraded.

 

Any one else having the same issue?

 

Firmware upgrade:

[root@xxxx tmp]# ./CP023869-p410i-6.60-G6.scexe

 

This program consists of two phases: device discovery and device update.

No device will be updated until you answer.

 

Do you want to run device discovery?
(yes/no) yes

 

Finding hardware. This may take a few minutes.
Found 0 devices.

 

No device will be updated.
No devices updated.

 

Controller Details:

Smart Array P410i in Slot 0 (Embedded)
Bus Interface: PCI
Slot: 0
Serial Number: 5001438010FED130
Cache Serial Number: PACCQID10502707
RAID 6 (ADG) Status: Disabled
Controller Status: OK
Hardware Revision: C
Firmware Version: 6.40

5 REPLIES
jorgesoto
Occasional Advisor

Re: BL460c G6: Unable to upgrade controller P410i

Update:

Same is happening with new 6.62 firmware. Also happening when try to upgrade from 6.60 to 6.62.

Jimmy Vance
HPE Pro

Re: BL460c G6: Unable to upgrade controller P410i

What OS are you using? A known issue with RHEL 7.1 is the 'sg' driver doesn't load during boot. If you happen to be running RHEL 7.1 'modprobe sg' and try running the .scexe again

 

 

 

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
jorgesoto
Occasional Advisor

Re: BL460c G6: Unable to upgrade controller P410i

Tried from RH 5 and 6 (32 and 64), other .scexe files are OK, and was also OK up tu version 6.40.

jorgesoto
Occasional Advisor

Re: BL460c G6: Unable to upgrade controller P410i


Jimmy Vance wrote:

What OS are you using? A known issue with RHEL 7.1 is the 'sg' driver doesn't load during boot. If you happen to be running RHEL 7.1 'modprobe sg' and try running the .scexe again



Jimmy, I just tried the modprobe sgbut still not working.

 

[root@xxxx tmp]# modprobe sg


[root@xxxx tmp]# ./CP025735-p410i-6.62-G6.scexe

 

This program consists of two phases: device discovery and device update.
No device will be updated until you answer.

 

Do you want to run device discovery?
(yes/no) yes

 

Finding hardware. This may take a few minutes.
Found 0 devices.

 

No device will be updated.
No devices updated.

jorgesoto
Occasional Advisor

Re: BL460c G6: Unable to upgrade controller P410i

Anyone found a workaround for this? Still not able to upgrade from 6.40, any version after will not detect the controller.