HPE BladeSystem Server Blades
cancel
Showing results for 
Search instead for 
Did you mean: 

Boot from disk problems - BL685c G1

PDP-Fan
Regular Advisor

Boot from disk problems - BL685c G1

I have an unusual problem with an BL685c Gen1. There are two internal disks (raid1 on Smart Array controller) and everything is set up to boot from that drive.

When I power up the system it skips "booting from C:" and tries to boot from the NIC. Then after a CTRL-ALT-DEL and after repeating the POST, it boots from c: without an issue.

 

- I did a factory reset of the BIOS

- updated the BIOS

- changed boot order (hard disk first)

- checked the boot controller order

- tried another mainboard (and had the same issue)

- set ASR to disabled in BIOS

- changed the CMOS battery (which was empty)

 

I also set the Broadcom NIC boot setting from "PXE" to "none". The result was that the blade did still not boot from the disk at first try but returned an error message "no or defective boot disk". After a ctrl-alt-del it booted from that disk.

 

No matter what I try to do, this blade does not boot from the disk after power up. Only after a ctrl-alt-del it will do.

After booting the system works without a problem....

***********************************************
"If it seems illogical... you just don't have enough information"
2 REPLIES
Torsten.
Acclaimed Contributor

Re: Boot from disk problems - BL685c G1

Does the evil smart array E200i has firmware 1.86?

 

From fixes list:

 

Problems Fixed:

  • Fixed an issue where logical drives were not being detected during POST or reboot on the HP Smart Array E200i controller with firmware version 1.80, 1.82 or 1.84.

 

 

http://h20564.www2.hp.com/hpsc/swd/public/detail?sp4ts.oid=3182564&swItemId=MTX_82d5b3d20c5f4c148e418fa2c4&swEnvOid=1005#tab4


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
PDP-Fan
Regular Advisor

Re: Boot from disk problems - BL685c G1

It is something with 1.8x, must have a look....

 

But I think I solved the problem already. I found that the disks I was using came from another server. Maybe not even a BL685c. I installed two new drives and did the whole setup process with the Smart Start DVD and Windows 2008... The Blade boots now correctly fron the newly installed disks.

 

I must say that I swap disks very often from one machine to another and normally I don't have problems. The Smart Array controllers are very user friendly in that point of view. This was the first time I had such a strange problem.

***********************************************
"If it seems illogical... you just don't have enough information"