HPE BladeSystem Server Blades
cancel
Showing results for 
Search instead for 
Did you mean: 

Proliant BL45P G1, BL25P G1 and BL25P G2

João Correia
Occasional Visitor

Proliant BL45P G1, BL25P G1 and BL25P G2

Hello,
I upgraded te ilo's to the version 1.94.
Now i can't access the virtual media on the ilo.
It gives me this error :
"load: class com.compaq.issg.lom.virtdevs.virtdevs.class not found.
java.lang.ClassNotFoundException: com.compaq.issg.lom.virtdevs.virtdevs.class
at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: java.io.IOException: open HTTP connection failed:https://192.168.10.193/com/compaq/issg/lom/virtdevs/virtdevs/class.class
at sun.plugin2.applet.Applet2ClassLoader.getBytes(Unknown Source)
at sun.plugin2.applet.Applet2ClassLoader.access$000(Unknown Source)
at sun.plugin2.applet.Applet2ClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
... 7 more
Exception: java.lang.ClassNotFoundException: com.compaq.issg.lom.virtdevs.virtdevs.class"

I've test it on IE8, IE7, Firefox. And with Java 1.4.2, Java 5 and Java 6, with the last updates and without updates.

I've tried what it says on this post
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&taskId=110&prodSeriesId=341566&prodTypeId=15351&prodSeriesId=341566&objectID=c00770929

But without success.

 

 

P.S. This thread has been moevd from ProLiant Servers (ML,DL,SL) to HP BladeSystem Server Blades. - Hp Forum Moderator

5 REPLIES
Dominik Hunn
Occasional Visitor

Re: Proliant BL45P G1, BL25P G1 and BL25P G2

Hi,

Did you install the update through the Version Control Agent (VCA)?
I've had exactly the same problem after updating from 1.89 to 1.94. After some troubleshooting, I noticed that for some reason, VCA installed the Japanese version of the iLO firmware update on my systems.
Selecting the English version manually with 'force re-install' ticked solved the problem for me (don't forget the reboot).

Yours,

Dominik
Michal Krnak
Occasional Visitor

Re: Proliant BL45P G1, BL25P G1 and BL25P G2

Thanks to Dominik for good idea, downgrade of iLO FW fix the issue for me.
PavelForum
Occasional Advisor

Re: Proliant BL45P G1, BL25P G1 and BL25P G2

You can upgrade iLO Firmware. Yes, from version 1.94 to version 1.94! After upgrading iLO will be rebooted and Virtual Media applet will be Ok.

Online ROM Flash Component for Windows - HP Integrated Lights-Out: http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=397638&prodNameId=3288140&swEnvOID=4024&swLang=8&mode=2&taskId=135&swItem=MTX-6011807da53845899bda5311ba

Extract files from package cp010535.exe to temp folder and use ilo194.bin file to upgrade iLO from Web interface.
VIK2011
Occasional Visitor

Re: Proliant BL45P G1, BL25P G1 and BL25P G2

Re-instaling 1.94 from web interface worked, but had to clear browser cache before making it to work.

Jimmy Vance
HPE Pro

Re: Proliant BL45P G1, BL25P G1 and BL25P G2

Whenever iLO firmare is updated it is suggested that you clear the browsers cache. I'm pretty sure it's documented with the firmware update instructions.




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!