HPE BladeSystem Server Blades
cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrading Blade firmware

SOLVED
Go to solution
johnmaag
Occasional Contributor

Upgrading Blade firmware

I need to upgrade the firmware on a BL460 G7. specifically the builtin network controller because of the following:

Jul 15 23:23:03 maui kernel: be2net 0000:02:00.0: FW not responding
Jul 15 23:23:03 maui kernel: be2net 0000:02:00.0: eth%d: Link down
Jul 15 23:23:03 maui kernel: be2net 0000:02:00.0: PCI INT A disabled
Jul 15 23:23:03 maui kernel: be2net 0000:02:00.0: Emulex OneConnect(be3) initialization failed
 
I have never done this and so far all of my attempts have not succeeded. When I downloaded specific firmware .scexe file it reports ther eis nothing to update.
 
I downloaded a firmware dvd for a 460c G7 blade last night and tried the dvd and it says also there was nothing to do.
 
The builtin network works on a cisco blade switch but does not on a virtual connect module. Not sure what is going on ther ebut hence the attempt to upgrade firmware.
 
I do nto have access to HP support and so am limited on what firmware I can download. If anyone has a tried and true method I would sure appreciate it.
3 REPLIES
Thomas Martin
Trusted Contributor
Solution

Re: Upgrading Blade firmware

Hello,

maybe you have a corrupt FW of the Emulex Network card. You have to flash them with an older version.

http://h20564.www2.hpe.com/hpsc/swd/public/detail?swItemId=co_106538_1

Check your POST of the Blade until the Emulex card came up. See VMware post:

https://communities.vmware.com/message/2560877

The FW for the Emulex card mentioned in the post is no longer available. Use the older version above.

Flash your Emulex card with this version and then you can flash it with the last one. I have done this with some of my Blades.

Thomas

johnmaag
Occasional Contributor

Re: Upgrading Blade firmware

Thanks for your reply Thomas. One of my concerns is technique. I used the firmware version 2016.10.05 from here:

http://h20564.www2.hpe.com/hpsc/swd/public/readIndex?sp4ts.oid=4324631&swLangOid=8&swEnvOid=4103

and it said there was nothing found.

I also tried the firmware DVD from here

http://h20564.www2.hpe.com/hpsc/swd/public/readIndex?sp4ts.oid=4194638&swLangOid=8&swEnvOid=4103

but it also said there was nothing to update. I will try your link below but I am wondering what I am doing wrong that nothing I seem to try has worked

johnmaag
Occasional Contributor

Re: Upgrading Blade firmware

Thank you Thomas I was able to succesfully upgrade the Emulex firmware. This unfortunately did not fix my issue but I know what it is not now. I am going to chase a hardware issue and do some experiments to determine if it is blade/chassis/Flex-10 module.

Thank you so much for your assistance.