HPE BladeSystem Server Blades
cancel
Showing results for 
Search instead for 
Did you mean: 

iLO 4 Clock Synchronized to OA Clock

SOLVED
Go to solution
Kasmar
Occasional Visitor

iLO 4 Clock Synchronized to OA Clock

Hello,

 

I am having issues synchronizing the iLO 4 clock to the same time as my OA device.  I want to have iLO sync to OA while OA is set with a manual time, no NTP server involved.

 

There is an option in iLO 4 to propagate the OA time to the host (iLO should get its time from the host if there is no NTP setup).  I disable the options to use the DHCP supplied time and add the OA address to the time server text box (might not have to do this since OA should supply the time when no NTP servers are available).

 

After iLO restarts, the time is not synchronized to OA.  I currently have OA set a day ahead to rule out a timezone issue.  Also, my VC device is pulling the same time from OA.  Is there something I am missing?

 

BTW, I know an NTP server would solve the time difference but I am not in that situation.

4 REPLIES
Oscar A. Perez
Honored Contributor
Solution

Re: iLO 4 Clock Synchronized to OA Clock

By design, iLO syncs its clock with the OA only when the blade is inserted or e-fused.  Same rule applies to iLO propagating the time it got from OA to the server RTC.  However, the propagation of time from iLO to host RTC can be disabled with current iLO3/iLO4 firmware versions.  

 

 




__________________________________________________
If you feel this was helpful please click the KUDOS! thumb below!
Jimmy Vance
HPE Pro

Re: iLO 4 Clock Synchronized to OA Clock


Kasmar wrote:

I disable the options to use the DHCP supplied time and add the OA address to the time server text box.


I'm pretty sure the OA doesn't advertise an NTP service and shouldn't  respond to NTP type requests. Using the OA IP in iLO as the NTP server won't work.

As Oscar has stated, iLO time should sync with the OA upon blade insertion, or tripping the e-fuse

 

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Kasmar
Occasional Visitor

Re: iLO 4 Clock Synchronized to OA Clock

Thanks for the help, Oscar and Jimmy.  The E-Fuse reset did sync the two clocks.  I was only resetting iLO at the time.  

 

Another issue I had after that was the mismatched time zones.  This is shown in the iLO Event Log with the description of "On-board clock set; was 02/04/2015 10:20:30"  after the reset.  So if anyone else has a problem with the time zones, there is the one in iLO under the SNTP settings, one in the Blade Server's RBSU under Date and Time, and the one in OA under Date and Time. I set them all to the same and did the E-Fuse reset again.  Now all the times are correct.

nicolaspla
Occasional Contributor

Re: iLO 4 Clock Synchronized to OA Clock

Hi Kasmar,

could you sync the timezone beteween the OA and the iLOs ?

 

I made a post, but I don't have any answer, http://h30499.www3.hp.com/t5/HP-BladeSystem-Server-Blades/iLO-issues-with-Time-Zone-sync/td-p/6783490#.VfL-qJ3BzGd

 

Thanks

Diego