HPE BladeSystem Server Blades
cancel
Showing results for 
Search instead for 
Did you mean: 

iscsi boot secondary targets not going through to linux 650FLB

reed_dba
Occasional Visitor

iscsi boot secondary targets not going through to linux 650FLB

Hi,

 

We have just purchased some bl460c G9 servers with the built in 650FLB Flex Nics.

 

We are installing Oracle Linix 7.1 (tho also tried redhat, oracle and centos 7.0 and redhat 7.1 and fedora 22) using iscis boot.

 

in Virtual Connect the profile is setup to have 2 iscsi ports, they have the same initiator name  are setup with 2 targets each, a primary and secondary. So 4 targets/ disks in total (which will multipath to be 1 disk)

 

The secondary targets never come through to anaconder.  Oddly they do for vmware esx 6.

 

Even more oddly if we put 1 target in each port as a primary, eg xxxx.198 and xxxx.197, anaconder will add in 2 more paths and show 4 disks,  I guess the software initiator addes them in, but once in the  installed OS they are not there, just the 2 primarys.

 

If we just have one port setup with a primary and secondary set, anaconder only sees 1 disk from the primary target.

 

We think this is something that has changed since Redhat 6 level as with our older G7 serers we can see the same behviour happening, ie redhat 5 shows 4 paths, but 6 shows just 2, same target setup.

 

Probably something do to with the be2iscis driver not seeing the secondary target any more.. ?

 

Anyone out there have any experience of this ?

 

 

many thanks, Chris

1 REPLY
AkiraX
Advisor

Re: iscsi boot secondary targets not going through to linux 650FLB

No experience with this but having issues with 650FLB adapter in a Windows 2012R2 environment.