HPE EVA Storage

Business Copy jobs fail after IP change.!

 
SOLVED
Go to solution

Business Copy jobs fail after IP change.!

Business Copy v2.3
Command View EVA v5.0.3 Build 2
Storage: EVA 3000
Connected Servers OS: Tru64 5.1B
Management Server OS: Windows 2003

I know that we are using very old management applications but since an upgrade involves a lot of change in the operation part we have postponed this to a later time.

Case:
This weekend we have swapped the IP addresses of two Tru64 servers. They are running properly without any problem. The only problem we are facing is with BC jobs, all of them are failing.

I think that this is related to BC Server (ComVw EVA Mngmt is also on the same server) because it seems like it doesn't recognize the change of IP on these systems.

I modified some of the jobs to reflect the new changes but they are still failing.

I assume that if I;
1. also swap the IP addresses of these servers on CommandView EVA
2. Reboot Business Copy Server
these will solve my problem

On the other hand I have doubts for how it will affect running environment if I reboot BC Server.

Any comments or helps are welcome...
Regards,
CET

5 REPLIES 5
ks6542
Valued Contributor

Re: Business Copy jobs fail after IP change.!

Yes truely,it happens because of the IP change.

Both the primary and secondary system should communicate.

If the systems are reachable,try pinging with new IP from both end.. after that you need to modify the horcm script.

Your horcm.conf file contain this section:
# Dev_group ip_address service/port
#HORCM_INST

HORCM_INST
hostA X.X.X.X horcmX

You need to modify this file with new IP and after that restart your horcm services will work..
you have to do it at both end..

Alternate if you switch back to origional IP .. it will work too :P

Hope I answer your query..
ks6542
Valued Contributor

Re: Business Copy jobs fail after IP change.!

I am sorry for the previous post.. it dosnt work in case of eva . my mistake
SAN_8
Frequent Advisor
Solution

Re: Business Copy jobs fail after IP change.!

Is there any firwall between management station and the true64 , if so you have to open the port for BC. if not just check in the host file where BC running the old ip of true 64 is there or not. modify the ip in hosts and recreate the job in BC

Re: Business Copy jobs fail after IP change.!

I really appreciate your quick responses but I solved the problem yesterday by doing the following...

LINE 4 and 5 IS SUPPORTING MY THEORY...
1. Edit /etc/hosts files on both servers with new IPs (done before IP swap)
2. Edit ../system32/drivers/hosts file with new IPs on BC Server
3. Modify DNS host records
4. Swap the IP addresses also on EVA CommandView for these two servers
5. Reboot BC Server (ensure that no jobs are running while performing reboot). So rebooting doesn't affect anything if you don't have jobs running.
6. UNDO any previous jobs and delete them (depends on case)
7. Create new jobs with new settings (depends on case)

And all jobs are running smoothly so far. Hope this entry helps some other guys later

Re: Business Copy jobs fail after IP change.!

Solution worked for me...