HPE EVA Storage

CVEVA 9.2 install failure - app already installed?

 
Adrian Graham_1
Regular Advisor

CVEVA 9.2 install failure - app already installed?

Folks,

Trying to update Command View 8 to 9.2 so I can upgrade XCS on an EVA4400. The uninstall completed successfully followed by a reboot, however the install didn't materialise on login as expected.

Running the installer manually and I get a popup saying 'the same version of this application is already installed, please uninstall'.... only it isn't installed - nothing under \program files\hewlett-packard\, nothing obvious in the registry etc. Anyone know what the installer is looking for?

Cheers
5 REPLIES 5
Torsten.
Acclaimed Contributor

Re: CVEVA 9.2 install failure - app already installed?

Where did you get this version? Where did you get this "upgrade XCS" (number?) version, that requires 9.2?
Ask your source.

However, I started exactly the same this evening (CV 9.2 install on an existing 9.1) - it tells me it will remove the older version and reboot, but there was no installer seen after that, then I left ... :-)


This confirms my opinion to always remove the older version first, reboot, then install manually.

I will see what my test box do tomorrow...

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Uwe Zessin
Honored Contributor

Re: CVEVA 9.2 install failure - app already installed?

CV 9.2 is here:
https://h20392.www2.hp.com/portal/swdepot/displayProductsList.do?category=SWSDED

When I looked yesterday, V9.1 was still there, but it no longer today.
.
Adrian Graham_1
Regular Advisor

Re: CVEVA 9.2 install failure - app already installed?

Hi Torsten,

I used 9.2 from the Software Depot (probably the same link Uwe's posted) because we all know HP's mantra is 'use the latest version or else we won't talk to you' ;)

XCS is 9522 from the Depot too which I think is CVEVA 9.1 compatible, if 9.2 doesn't play nice I'll install 9.1.

Let me know how you get on... life at the cutting edge eh...
Adrian Graham_1
Regular Advisor

Re: CVEVA 9.2 install failure - app already installed?

OK, a bit more info. I've cleaned everything out of the registry that mentions Command View, SANworks, HPOvLic and SMI-S, there's definitely nothing left under program files\hewlett-packard\ that shouldn't be there and I still get the error even logged on as a local administrator.

This time I've found a log file containing this:

Execute Custom Code
class CheckOSCompatible.install() Unexpected Fatal Error:
java.lang.UnsatisfiedLinkError: IsAdmin
at OSNativeMethodsJNI.IsAdmin(Native Method)
at CheckOSCompatible.install(CheckOSCompatible.java:90)
at com.zerog.ia.installer.actions.CustomAction.installSelf(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.a(DashoA8113)
at com.zerog.ia.installer.AAMgr.a(DashoA8113)
at com.zerog.ia.installer.AAMgr.a(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.e(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.m(DashoA8113)
at com.zerog.ia.installer.AAMgr.a(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.e(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.m(DashoA8113)
at com.zerog.ia.installer.AAMgr.a(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.e(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.m(DashoA8113)
at com.zerog.ia.installer.AAMgr.a(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.e(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.m(DashoA8113)
at com.zerog.ia.installer.AAMgr.a(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.e(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.m(DashoA8113)
at com.zerog.ia.installer.AAMgr.a(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.e(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.m(DashoA8113)
at com.zerog.ia.installer.AAMgr.a(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.e(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.m(DashoA8113)
at com.zerog.ia.installer.AAMgr.a(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.e(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.m(DashoA8113)
at com.zerog.ia.installer.AAMgr.a(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.e(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.m(DashoA8113)
at com.zerog.ia.installer.AAMgr.a(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.e(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.m(DashoA8113)
at com.zerog.ia.installer.AAMgr.a(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.e(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.m(DashoA8113)
at com.zerog.ia.installer.AAMgr.a(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.e(DashoA8113)
at com.zerog.ia.installer.AAMgrBase.m(DashoA8113)
at com.zerog.ia.installer.AAMgr.actionPerformed(DashoA8113)
at java.awt.Button.processActionEvent(Unknown Source)
at java.awt.Button.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)


which kind of implies it doesn't think I'm an admin even though I am AND the local admin account is in the required HP storage groups.
Adrian Graham_1
Regular Advisor

Re: CVEVA 9.2 install failure - app already installed?

wait - old Java version on the CVEVA box. I've just tried the same procedure on an XP Virtual machine and it's worked, though it didn't automatically fire up the installer after removing an older version and rebooting. Versions here are 1.6, the CVEVA is 1.5. I'll update and let you know.