HPE EVA Storage

Cannot format a disk on our HP EVA 4400 SAN from our new Dell PowerEdge M710 blade.

 
glenn1179
Occasional Advisor

Cannot format a disk on our HP EVA 4400 SAN from our new Dell PowerEdge M710 blade.

We cannot format a disk on our HP EVA 4400 SAN from our new Dell PowerEdge M710 blade. This blade and disks are not part of a cluster after we had the issues covered in this thread:

http://social.technet.microsoft.com/Forums/en-US/winserverClustering/thread/d8058f2c-8c86-4c20-9291-36840b21dd0d


We did a fresh format and install of W2K8 64 bit Datacenter SP2 (Full) with Hyper V on the M710 with a Qlogic QME2572 HBA. I requested one 40 GB lun from our HP EVA 4400 SAN be presented and tried to quick format it. It failed with the pop-up error, "The format did not complete successfully." I let a normal format run for 4 hours and it only completed 10%, so I cancelled it. I can’t find any entries of errors in the event logs that appear to be related. The same lun was then presented to a Dell Poweredge M600 blade in the same chassis with a Qlogic QME2472 HBA and I was able to format it from that machine in about a minute. Just for kicks I tried formatting a USB drive to NTFS on the M710 and that worked. I also tried swapping the HBA's between the M710 and M600 and I still wasn't able to format the lun from the M710. I tried updating the HBA driver on the M710 from 9.1.4.6 to 9.1.8.16 and the quick format still fails.
9 REPLIES 9
Uwe Zessin
Honored Contributor

Re: Cannot format a disk on our HP EVA 4400 SAN from our new Dell PowerEdge M710 blade.

Glenn,
what Windows version was running on the M600?
I've seen this behaviour with Windows Enterprise Edition, too. This seems to be a little bug, because EE (and I guess DC as well) does not automatically assign a drive letter and mount a new volume in some cases.
.
glenn1179
Occasional Advisor

Re: Cannot format a disk on our HP EVA 4400 SAN from our new Dell PowerEdge M710 blade.

The M600 is also W2K8 64 bit Datacenter SP2 (Full) install.
Uwe Zessin
Honored Contributor

Re: Cannot format a disk on our HP EVA 4400 SAN from our new Dell PowerEdge M710 blade.

OK, but at that time the disk wasn't completely empty any longer, was it?
.
glenn1179
Occasional Advisor

Re: Cannot format a disk on our HP EVA 4400 SAN from our new Dell PowerEdge M710 blade.

The 40 GB disk was still completely empty when presented to the M600 because it couldn't be formatted for use from the M710.
Uwe Zessin
Honored Contributor

Re: Cannot format a disk on our HP EVA 4400 SAN from our new Dell PowerEdge M710 blade.

Does that mean you have removed the partition table and the signature?
.
glenn1179
Occasional Advisor

Re: Cannot format a disk on our HP EVA 4400 SAN from our new Dell PowerEdge M710 blade.

No, the partition table and the signature were not removed.
glenn1179
Occasional Advisor

Re: Cannot format a disk on our HP EVA 4400 SAN from our new Dell PowerEdge M710 blade.

How does one remove the partition table and the signature on an empty lun with out destroying anything else?
glenn1179
Occasional Advisor

Re: Cannot format a disk on our HP EVA 4400 SAN from our new Dell PowerEdge M710 blade.

This issue appears to be resolved by finding the right combination of drivers to get this to work.
glenn1179
Occasional Advisor

Re: Cannot format a disk on our HP EVA 4400 SAN from our new Dell PowerEdge M710 blade.

Found the right drivers to get the device to work properly.