HPE EVA Storage

CmdView only listening on 127.0.0.1? How do I widen that?

 
Trever Furnish
Regular Advisor

CmdView only listening on 127.0.0.1? How do I widen that?

One of our commandview installations is only accessible on https://localhost:2372/Login, not on the other IP addresses on the box. It's just not bound to the other IP addresses. Can anyone tell me why, or how to fix?

It looks like it's bound correctly to the wildcard address -- but when I go to any address other than 127.0.0.1 on port 2372 in a browser, I get 'connection refused'. Seems pretty odd.

Here's the output of netstat, filtered down to just port 2372:

C:\Users\tgfadmin>netstat -aon | find "2372"
TCP [::]:2372 [::]:0 LISTENING 792
TCP [::1]:2372 [::1]:51310 ESTABLISHED 792
TCP [::1]:2372 [::1]:51327 ESTABLISHED 792
TCP [::1]:2372 [::1]:51328 ESTABLISHED 792
TCP [::1]:2372 [::1]:51329 ESTABLISHED 792
TCP [::1]:2372 [::1]:51330 ESTABLISHED 792
TCP [::1]:51310 [::1]:2372 ESTABLISHED 9568
TCP [::1]:51327 [::1]:2372 ESTABLISHED 9568
TCP [::1]:51328 [::1]:2372 ESTABLISHED 9568
TCP [::1]:51329 [::1]:2372 ESTABLISHED 9568
TCP [::1]:51330 [::1]:2372 ESTABLISHED 9568
Hockey PUX?
4 REPLIES 4
gordonf4hp
Occasional Advisor

Re: CmdView only listening on 127.0.0.1? How do I widen that?

Assuming this is a Command View installation on a fairly modern Windows PC, is the Windows Firewall configured to allow inbound connections to Command View?

This suggests it's listening on all IPs:

TCP [::]:2372 [::]:0 LISTENING 792

I don't know IPv6 enough yet, but I'll go out on a limb and say the lack of a "::1" descriptor for listening suggests it's listening on all known IPs.

Windows Server 2008 and 2008 R2 have the firewall enabled by default, which was the reverse of Server 2003. You can either make a port exception for 2372, or you could do an application exception for the Command View service, whose executable's name eludes me for the moment.

What does netstat -abon tell you about what application has port 2372 open? You'll need to run that command with elevated privileges (run as administrator) to obtain the executable names. Then you can add the application to the firewall rather than add its ports.
Trever Furnish
Regular Advisor

Re: CmdView only listening on 127.0.0.1? How do I widen that?

Thanks, Gordon,

The windows firewall is already fully disabled on the server, and netstat -abon shows cveva.exe as the process listening on tcp 2372.

Still can't connect to it on the non-local address though. :-(

(BTW, thanks for pointing out the -b option of netstat -- I didn't realize they'd added that and it'll be a timesaver in the future.
Hockey PUX?
Sivaramakrishna_1
Honored Contributor

Re: CmdView only listening on 127.0.0.1? How do I widen that?

Hi,

Can u try to add the IP address and hostname in hosts file (system32\drivers\etc) and restart the HP Command View EVA Service.

I hope IPV6 is also enabled on the network interface. You can try disable IPV6 if u are not using and restart the Command View Service.
Mr Will
Visitor

Re: CmdView only listening on 127.0.0.1? How do I widen that?

I was experiencing the same symptoms after installing CV 9.4 on a Win2008R2 SP1 machine.

Here's how I fixed mine:
1. find cveva.cfg (mine was in C:\Program Files (x86)\Hewlett-Packard\Sanworks\Element Manager for StorageWorks HSV\config)
2. under Section WebServer, add the following: address 0.0.0.0
3. restart HP Command View Service

So in my case CV bound itself (by default) to the ipv6 address of my machine.

Hope this helps.