HPE EVA Storage

Command View EVA install 'hangs'

 
Rob Leadbeater
Honored Contributor

Command View EVA install 'hangs'

Hi,

I had to do some maintenance on an SMA III recently and subsequently I can no longer get CV EVA 5 or 6 to install.

The SMA was originally running CV EVA 5.0.3. I had to do some work on an old EVA running VCS 2.006 so I downgraded CV to 3.2. Having upgraded the EVA, I'm now trying to get Command View back up to 5.0.3 however the installation just appears to hang...

Basically, I run setup.exe and the first couple of InstallShield dialogs appear, but then nothing - I don't get the usual CV setup screens...

Looking at Task Manager, I can see setup.exe is still running, and there is also what I believe to be a related java.exe - but nothing appears to be doing anything...

This is running from the CV 5 install CD. The same thing happens with CV 6 CD.

Any ideas ?

Cheers,

Rob
12 REPLIES 12
Ivan Ferreira
Honored Contributor

Re: Command View EVA install 'hangs'

Please remove any command view previuosly installed before trying to install the latest, and also, be patient. Once I had a similar problem, left to my home, returned to the other day, and the installation process continued.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Rob Leadbeater
Honored Contributor

Re: Command View EVA install 'hangs'

Thanks Ivan,

All previous versions of CV are already removed. I kicked off another installation around an hour ago, and so far nothing has happened on the screen. I'll see what happens in the morning !

Cheers,

Rob
Ivan Ferreira
Honored Contributor

Re: Command View EVA install 'hangs'

After removing the old command view eva and before install the new one, please ensure to reboot the SMA just to ensure that nothing is blocking the setup process.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Mynor Aguilar
Valued Contributor

Re: Command View EVA install 'hangs'

As far as I remember, downgrading CV is not advisable. that might be the source of your problems. Anyway, try to upgrade to CV 4.1 before 5.0.3 because It's is incremental.
Rob Leadbeater
Honored Contributor

Re: Command View EVA install 'hangs'

Hi,

Well after 15 hours of waiting, nothing had happened, so I killed the setup.exe process...

I've now reinstalled CV 4.1, which does appear to work OK, however both the CV 5 and 6 installs still fail in the same manner as before... I think I'm going to have to dig out the SMA Quick Restore CD :-(

Cheers,

Rob
Rob Leadbeater
Honored Contributor

Re: Command View EVA install 'hangs'

Hi again,

A bit of debugging with SysInternal's Process Explorer, shows that there is something amiss with Java...

The java.exe process, which is spawned from setup.exe is sitting in a "Wait:UserRequest" state. However there is nothing on the screen to be able to respond to...

A similar thing happens when attempting to fire up a Java console, so it doesn't appear to be directly related to the Command View install... I'll keep digging !

Cheers,

Rob
Rob Leadbeater
Honored Contributor

Re: Command View EVA install 'hangs'

Hi,

I eventually got this resolved without having to resort to the restore CD...

Because other Java applications weren't working correctly, I figured that this must be something to do with Java on the SMA.

Whilst looking through the list of processes, I noticed a process called MSJavaWrapper.exe. I figured this might have something to do with the issue. I initially thought it was something to do with Microsoft, however eventually worked out the culprit was in fact the "HP OpenView SAM Management Server" service. Stopping this service enabled Java applications, including the Command View installs, to work again.

Cheers,

Rob
Yoeri Coenradie
New Member

Re: Command View EVA install 'hangs'

Thanks for this post!

It helped me to install CV EVA 7.0 and patch it to 7.0.1 on our SMA III. I had to disable the service "HP OpenView SAM ManagementServer". The installer did not always continue after a reboot, but I tried it a couple of times and eventually everything went fine.

It might be a good idea for HP to put this in the Installation Guide/Release Notes...
Andre Stewart
Frequent Advisor

Re: Command View EVA install 'hangs'

Does anyone happen to have the release notes to 7.0 (I do have the 7.0.1 release notes)? I'm currently at 6.0.2 and trying to upgrade to 9.x, I think I need to jump to 7.x prior to going directly to 9.x, right?

I have the installer for CV EVA 7.0.0.57, but I do not have the relase notes. I just want to make sure I have all the prerequisites and conflicts resolved before just 'jumping in'.

Andre