HPE EVA Storage

Connectivity problems EVA 3000

 
d0kt0r
Frequent Advisor

Connectivity problems EVA 3000


Hope you can help me out with this!!!

HP EVA 3000, with controller HSV110.
SAN Brocade Fabric Switch 200E.
Server(non HP) with FC card Emulex LPE1150. Operating System Windows 2008 x64.

On the brocade, I can see both WWNs (server and EVA). I never did any zoning configuration, but I created aliases for the EVA and for the server, and created a Zone for both servers. Saved and enabled the configuration.

The EVA has all the indicators in green. Cab ID is 02, and the rest of the links are green.

Then, I went to the server, and installed Command View 6. Installation correct. But, when i go inside, it says me it can't find any storage system. Tried to re-discover but, inmediately it says "No Controllers".

I think should be a connectivity problem between the HSV Controller to the server (more than the HSV and the Disk Shelf), but can't find where Im screwing it up. The zoning is only with 2 WWNs so, i can't do much more things there.

Thanks in advance guys, you are the best!!
7 REPLIES 7
d0kt0r
Frequent Advisor

Re: Connectivity problems EVA 3000


Still doing more testing.
In the OCP it says "NO STORAGE SYSTEM", but I guess I will have to initialize the storage via Command View.

Tried to direct connect via FC cable EVA and server, but it doesn't like it : The green led on the FP1 Host port only gets green when is connected to the Brocade.

Tried on zoning to create on the same Zone, both server aliases and both switch ports. Still CV can't view anything.

It is for a lab environment, and we have only 1 HSV110. Loop 1A is connected to the 1st conector on the A disk shelf module. Same for the Loop 1B. I think we have change the loop order and we got a warning saying something about the loop. With this configuration, we have no warnings on the eva.

Nothing else so far.

I will have to investigate a bit more with the zoning ... but apart of that, Im lost in the problem!!!

Thanks a lot guys ... Giving points to all who can throw some light!!!
Martin Smoral
Trusted Contributor

Re: Connectivity problems EVA 3000

If there is no data to worry about, how about initialize the EVA through the Front panel. then try to discover via CV from the Server.
HenkW
Advisor

Re: Connectivity problems EVA 3000

Hello,

did you think about

cfgSave
cfgenable

Just my 2 cents
Bhavnish Kamboj (BK)
Trusted Contributor

Re: Connectivity problems EVA 3000

Initialize it from OCP and then check, if still no luck.

Please share output of zoneshow along with the details on which port EVA and servers are connected.
d0kt0r
Frequent Advisor

Re: Connectivity problems EVA 3000

Hi guys,

Sorry for the delay on the answer. Got some holidays.

I've attached some screenies of the brocade admin java applet, and the error I have on the command view.

I have done too 2 photos of the front/back of the shelf and the controller, just in case anyone wanna check the connectors. Can't attach them 2mb each. Provide me an email and ill send you the photos.

As I said, ill give out points to anyone who can help me out with this. I've spent a lot of money in this lab environment ... and it is really driving me mad to get so close and so far.

Cheers guys, thanks in advance.
Alex Georgiev
Regular Advisor

Re: Connectivity problems EVA 3000

This could be as simple as forcing your server to re-login to the fabric. Just physically unplug and replug the cable from your HBAs, then try again.

Other than that...

Your zoning looked fine. You don't need to include the ports as well as the aliases. I've only seen one or the other, never both. In my environment we do soft zoning, which means put the aliases in the zone only. I'm not sure if having both ports and aliases does any damage, though. I don't think that's the problem.

For troubleshooting I like to open the name server of each FC switch, the select a WWN and use the "Accessible Devices" button. That's a way to make sure your zoning is correct.

The other thing I like to do is use the Emulex tools on the host (HBAanywhere) to find out what the host sees.

Can you let us know what those look like if the first step doesn't work.
d0kt0r
Frequent Advisor

Re: Connectivity problems EVA 3000

Hi Alex,

Thanks for the answer.
I've got some useful information about it.

From the Brocade, through the option of Name Server, seems that both servers are visible each other (screenshots). And, using the Emulex OneCommand Manager (HBAnywhere), from the client, I CAN see the EVA Controller ...
But ... still the same error when trying to access via CommandView ... can't discover any storage.

Maybe I can access the controller, but can't access the disks? Maybe the connection between the controller and the shelf is wrong?

If you need I can post physical photos of the cabling ... But, more or less ... The shelf has only one GBIC on each controller (IO Card A and IO Card B) on the top (bottom GBIC is empty), so, from the controller, im only using the connectors Loop 1A, 1B.
I only have 1 controller, so, maybe there is a problem on the loop? It can be overpassed?

Thanks a lot for your time guys,