HPE EVA Storage

EVA 4100 battery failure

 
SOLVED
Go to solution
Antonio Francucci
Occasional Advisor

EVA 4100 battery failure

Hi all, we have a costumer with an EVA 4100 , that after a power failure reports problems to both controllers

 

The controllers are two HS200-B,

Controller A was is in "soft operational failure" and both blower detected at 0 RPM plus a battery failed.

Controller B has only a battery failed.

No LUNs showed to any of the four host , even if the presentation and zoning is ok and all the Vdisks are in GOOD status (that is by EVA design if i rememer well)

The EVA is no longer in warranty.

 

The costumer has spare parts for that type of failure and replaced it in both controller with no luck.

 

Investigating onsite the EVA we found that:
1) the controller with battery and blower failed (as reported by CV EVA) has the connector for battery module 0 almost fused (attached a photo)

2) the other controller, marks failed another battery (new) in module 0 but is in charging status with another (new) battery in module 1

 

The question is:

I know that all EVAs disable LUNs access with both controllers battery failed, but now that we have a battery on one of the controller charging, we should see the LUNs or not? we have to wait for the battery to charge?

 

Can we replace the fused backplane of the Controlle A?

4 REPLIES 4
Johan Guldmyr
Honored Contributor

Re: EVA 4100 battery failure

Hi!

You may be able to replace the backplane if you can find/create it.. but there's no HP spare part for it. You'd have to replace the controller (and maybe the battery that was installed as a replacement).

What if you disconnect/power down the controller with the almost fused battery connector?
In the other controller I'd take out the failed battery in module 0 on the other controller. Have you restarted the controller(s) as well?

Antonio Francucci
Occasional Advisor

Re: EVA 4100 battery failure

Hi there Johan and thank you for your response, the faulty controller (A) is powered off , the second (B) is charging  battery module 1 with a new battery, as in module 0  CV EVA report battery not installed but charging :smileysurprised:

 

We have restarted both controllers

Forgot to mention that the problems begun with a site power failure..

 

anyway with only one controller charging the battery no host can see the LUNs mapped to it, i dont think that this is normal, i'm right?

Antonio Francucci
Occasional Advisor

Re: EVA 4100 battery failure

Ok the Good controller has finished charging the new battery and the LUNs now are visible.

 

Now to replace the failed controller, any advice or best practices in doing that?

Johan Guldmyr
Honored Contributor
Solution

Re: EVA 4100 battery failure

Not really. I'm sure there's some kind of guide for it in a manual somewhere.

 

Shut off the broken one. Replace it and put in new batteries as well. Don't use old broken ones as they might break the connector inside the controller.