HPE EVA Storage

EVA4400 - Hidden LUN ??

 
Mads S. Andersen
Occasional Advisor

EVA4400 - Hidden LUN ??

Hi,

Got a customer with a strange problem.

An EVA 4400 FW:09501000 have a presented LUN that do not show up in CV.
The lun is working, but not showing.
The lun id is 4. But when I try to assign a new lun to some esx hosts. It auto picks 4, since it thinks it not in use. And I get an error. If I manually chose 5, it works just fine.

So some part of the EVA is aware of a LUN and even presenting it as lun 4. But CV can't see it. If I do a refresh on the EVA it get a "Temporary Disk Name: Virtual Disk X"(x changes every time+1). When I chose the disk, CV says "Deletion Completed".

So it looks like the disk/lun is in a kind of limbo state. Could be the missing lun 4.

So how do I nuke/delete/remove it ?

/Mads

9 REPLIES 9
Uwe Zessin
Honored Contributor

Re: EVA4400 - Hidden LUN ??

I strongly recommend that you open a call with HP and not attempt to fix it on your own!!

It might be necessary that an engineer does some low-level manipulation of the EVA meta-data area.
.
Víctor Cespón
Honored Contributor

Re: EVA4400 - Hidden LUN ??

Try to install Command View 9.1, it's better at handling inconsistent metadata.
HP technicians can perform a metadata check and attempt a repair, open a call and let them do it.
Mads S. Andersen
Occasional Advisor

Re: EVA4400 - Hidden LUN ??

First thing I did was contact HP.

Now we got at new manage module, and was told to upgrade the firmware's. HD from 05-06 and the just released firmware(XCS 09521000) 4.Aug 2009
Sigh, just come and fix it.

Btw. The HD firmware update, updated 2 disk out of 24 and killed 1 disk..

But HP still tells me to upgrade the fw before they will come..

More to come.. I WILL NOT upgrade the FW with alle the problems we seeing. HP can come and put there head on the block.

The last few years the HP support have become SO bad..
Víctor Cespón
Honored Contributor

Re: EVA4400 - Hidden LUN ??

XCS 09521000 is being installed by HP technicians on all customers that request it. Request information on this, AFAIK the idea is to get XCS 09521000 in all EVA4400s ASAP.
Mads S. Andersen
Occasional Advisor

Re: EVA4400 - Hidden LUN ??

I will try that. But my customer was quoted 4 hours for the install. As in $.

I have the new FW and have installed EVA for ages.

But seeing all the problem we have been having with this 4400, I get very cautious.
Loosing data is not an option:)

Again, HP Support= Phhffff.

It's a 24/7 contract.. And tomorrow we are reopening the case for the 3th time.
Víctor Cespón
Honored Contributor

Re: EVA4400 - Hidden LUN ??

Request a clarification on that. We are doing it for free in this country. I have just updated XCS and disk firmware on a customer's EVA4400.
It takes 1 hour and a half, plus whatever you need to stop applications and shutdown all servers using the EVA (it has to be done offline since it updates the I/O modules to firmware 073, and disk enclosures have to be shutdown after that.)
Mads S. Andersen
Occasional Advisor

Re: EVA4400 - Hidden LUN ??

I will do that..

And thanks for the heads up about downtime.
Not in the readme, I will investigate that.
There should be a "warning". Looks just like a plain vanilla update to me..

/M
Mads S. Andersen
Occasional Advisor

Re: EVA4400 - Hidden LUN ??

Ok, found the release notes. And they do state that it should be done offline. But would be nice if they were included with the update..

/M
Bert Zefat
Advisor

Re: EVA4400 - Hidden LUN ??

There is now firmware version 09522000. Please go directly to this version. You need CVE 9.1 to install 09520000 and up. After the (offline) upgrade, upgrade the disk firmware (not upfront as in earlier firmware there was an issue that could kill (FATA) disks.