HPE EVA Storage

EVA4K - server Red Hat 5 trying to use HPDM

 
SOLVED
Go to solution
geraldo gassen
Occasional Advisor

EVA4K - server Red Hat 5 trying to use HPDM

Hi, I'm trying to configure the HPDM in RED Hat 5.
When I start the service multipathd, I receive the error below:

# service multipathd start
device-mapper: table: 253:5: multipath: error getting device
device-mapper: ioctl: error adding target to table.
Iniciando daemon multipathd : [ OK ]
device-mapper: table: 253:5: multipath: error getting device
device-mapper: ioctl: error adding target to table

I tried to find this mistake in the google, but I didn't find this message.
Did anybody already go by this?

multipath.conf is below;
## Use user friendly names, instead of using WWIDs as names.
defaults {
user_friendly_names yes
}

multipaths {
multipath {
wwid 3600508b4000156d700012000000b0000
alias mpath1
}

device
{
vendor "HP"
product "HSV200"
path_grouping_policy group_by_prio
getuid_callout "/sbin/scsi_id -g -u -s /block/%n"
path_checker tur
path_selector "round-robin 0"
prio_callout "/sbin/mpath_prio_alua %n"
rr_weight uniform
rr_min_io 100
failback immediate
no_path_retry 12
}
-----//---
Thks,

 

 

P.S. This thread has been moevd from General to Storage Area Networks (SAN) (Enterprise). - Hp Forum Moderator

7 REPLIES 7
Sivakumar MJ._1
Respected Contributor

Re: EVA4K - server Red Hat 5 trying to use HPDM

Can u provide the output of

#dmsetup ls
Ivan Ferreira
Honored Contributor
Solution

Re: EVA4K - server Red Hat 5 trying to use HPDM

Ensure the WWID is correct. Check your device vendor and model configuration by running:

cat /sys/block//device/vendor
cat /sys/block//device/model

Post the output of:

mpathadm -v2

Is that your full configuration file? Ensure that in your configuration file you don't have blacklist enabled for all devices.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
geraldo gassen
Occasional Advisor

Re: EVA4K - server Red Hat 5 trying to use HPDM

The command mpathadm not found, I attach the out put of multipath -v3.
Ivan Ferreira
Honored Contributor

Re: EVA4K - server Red Hat 5 trying to use HPDM

From the output, I can see that your WWID is not correct:

3600508b4000156d700012000000b0000 (1)
3600508b4001042560001400000080000 (2)

Where the WWID above:

(1) Your configuration file
(2) The output of the command



Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
geraldo gassen
Occasional Advisor

Re: EVA4K - server Red Hat 5 trying to use HPDM

problem solve,

solution,
in the multipath.conf
:
blacklist {
wwid 3600508e000000000db511b1903bf040a
wwid 26353900f02796769
devnode "^(ram|raw|loop|fd|md|dm-|sr|scd|st)[0-9]*"
devnode "^hd[a-z]"
}
:
thks for your help.
Sivakumar MJ._1
Respected Contributor

Re: EVA4K - server Red Hat 5 trying to use HPDM

Hi Geraldo Gassen,

Please close this tread if your problem is solved.

Thanks in advance.
geraldo gassen
Occasional Advisor

Re: EVA4K - server Red Hat 5 trying to use HPDM

solution below

in the multipath.conf
:
blacklist {
wwid 3600508e000000000db511b1903bf040a
wwid 26353900f02796769
devnode "^(ram|raw|loop|fd|md|dm-|sr|scd|st)[0-9]*"
devnode "^hd[a-z]"
}
: