HPE EVA Storage

EVAPerf and EVA4400 management module?

 
Lars Bjerring
Occasional Advisor

EVAPerf and EVA4400 management module?

Hi

We have a HP EVA 4400 with a management module. We do not have a management server, only the management module.

Now I am trying to connect a EVAPerf server to the EVA4400 management module.
I found this in the “HP StorageWorks Command View EVA User Guide”. If I understand this right, is should be possible to use EVAPerf against a management module.

------from the user guide------
HP Command View EVAPerf is not installed or available on the EVA4400 management module.
However, with HP Command View EVA array-based management, you can install HP Command View EVAPerf on a server and use it to connect remotely to the management module and monitor the performance of the EVA4400.

You cannot execute the following commands from the remote HP Command View EVAPerf client:
• dpw wwn
• luns
• pfa [array]*
• pfd
• pfh
• pfs
• pfvd [vdisk]*
• spw WWN password
• vpw
• rc
------------------

I installed the EVAPerf server and client on a windows 2003 R2 (32bit) connected to the same LAN as the EVA management module. I Installed EVAPerf server and client from version 9.2 CD and module is also upgraded to the version located on the 9.2 CD.

This is what I did
evaperf cvconfig 10.10.10.40 2372 administrator@MGMTMOD
Entered the password.
Restarted “HP EVA Performance Data Collector” service

evaperf.exe verifycvconfig
Host Port Username Accessible
------- ---- ------------ ----------
10.10.10.40 2372 administrator@mgmtmod Yes

evaperf.conf, logging.conf are both default.

If I then run “evaperf.exe ls” I get this:
No EVA systems were found


Can someone please help me. What did I do wrong or what's missing ?


Lars
11 REPLIES 11
Anthony Martin_1
Frequent Advisor

Re: EVAPerf and EVA4400 management module?

Hi Lars,
The issue here is your server needs to be on the SAN fabric. In other words, it needs to have a fibre connection to the EVA.

Regards
Anthony
Lars Bjerring
Occasional Advisor

Re: EVAPerf and EVA4400 management module?

Hi Anthony

Thanks for you answer. If I run a "normal" management server I know it should be connected directly to the SAN by fiber.

But as it sayes i the user guide:
HP Command View EVAPerf is not installed or available on the EVA4400 management module.
However, with HP Command View EVA array-based management, you can install HP Command View EVAPerf on a server and use it to connect remotely to the management module and monitor the performance of the EVA4400.

It should be possible to monitor the Management module from the network from a EVAPref server ?

But maybe I should just install a normal management server :-)

Lars
Uwe Zessin
Honored Contributor

Re: EVAPerf and EVA4400 management module?

Last time I checked, EVAperf pulls the performance data from the EVA controller LUNs, so a Fibre Channel connect is required.

> But maybe I should just install a normal management server :-)

Yes, that is a good idea.
.
Lars Bjerring
Occasional Advisor

Re: EVAPerf and EVA4400 management module?

Ok, sorry I must have misread the user guide.

"However, with HP Command View EVA array-based management, you can install HP Command View EVAPerf on a server and use it to connect remotely to the management module and monitor the performance of the EVA4400."

I thought "connect remotely to the management module" was by LAN, as this is the only connection on the module.

But if I connect a management server by fiber, I don't need the module. Then why write this in the user guide ??

Lars
Uwe Zessin
Honored Contributor

Re: EVAPerf and EVA4400 management module?

Is "10.10.10.40" the address of the management module?
If it is the address of a server with CV-EVA installed but no EVA SAN connectivity, it will not work, as Anthony already said.
.
Lars Bjerring
Occasional Advisor

Re: EVAPerf and EVA4400 management module?

Hi

10.10.10.40 is the address of the management module.

As you can see, the "verifycvconfig" also sayes Accessible=Yes.

"evaperf fn" also lists all my Vdisk, hosts, ect...

but "evaperf ls" sayes
"No EVA systems were found"
Stefan Holzwarth
New Member

Re: EVAPerf and EVA4400 management module?

Any news to this problem?

I also tried to read performance data of a remote EVA using evaperf. Also got accessible message using evaperf fnh.

Whats the sense of this connect if i can not use it?
Marcin Wozniak
Advisor

Re: EVAPerf and EVA4400 management module?

Hello, I have the sam problem Did You figure this out? Thank You for an answer.

Command View is on EVA4400.
Lars Bjerring
Occasional Advisor

Re: EVAPerf and EVA4400 management module?

Hi

No, I'm sorry never got it working.

I put up a management server and connected to the EVA by fiber.

That will also make the web interface work much faster. The EVA management module was very slow to work with.