HPE EVA Storage

FC shared tapes devices disapearing

 
Gilbert Plouffe
Advisor

FC shared tapes devices disapearing

I did not know where to post this message,SAN or Tapes and libraries. Because this is related to FC devices i decided to post it on the SAN side

Hi there, since we had FC SDLT600 tapes device (20x Storagetek 2x L700 library) shared among 20 servers we are currently having some strange behaviour. We are a Microsoft, HP shop and from time to time the devices disappeared. When it happen on a Windows OS plug and play generate and error that the tape devices had disappeared and wasn’t removed properly. To bring back the devices we need to reboot the server. I suspect a HBA or fabric configuration. Here a high overview of our current san infrastructure.

Dual fabric with DCX and 48000. Tape devices are zoned on one fabric. Switch port for the
tape devices have been configured as G port. Port speed have been lockdown to 2 GB/s (tape devices speed), all tapes devices have their own alias and zone with the servers. Ten devices are connected to fabric A and the other on fabric B.

Thank you for taking time to read this discussion
11 REPLIES 11
Gilbert Plouffe
Advisor

Re: FC shared tapes devices disapearing

Fabric overview infrastructure (cont)

Tape Devices are FC SDLT6000 20x split on two Storagtek l700 libraries.

One library is zone on fabric A and the other on Fabric B
Patrick Terlisten
Honored Contributor

Re: FC shared tapes devices disapearing

Hello,

lose only one server at a given time a drive or are failing the drives at more then one server at a given time?

Regards,
Patrick
Best regards,
Patrick
Stephen Kebbell
Honored Contributor

Re: FC shared tapes devices disapearing

Hi,

we had similar problems with StorageTek Libraries (SL3000 with LTO Drives).
The drives were connected via Patch-Panels to the SAN Switches wth FOS 5.3.0d, and were logged in as L-Ports.
Every now and then, a server lost a tape device (not on all servers, although they were all zoned to the tape drive)
After a planned upgrade we put a SAN Switch (with FOS 6.3.0b) near the Tape Library, directly connected the devies, and locked the ports as G-Ports. The ISL now goes over patch panels.
Since then we have had no problems. I don't know what the root cause was: the FOS, the cabling/patchpanels or the Topology, I can't say.

What HBAs do you have in your servers? Do you have up-to-date Drivers? For the Windows servers, do you use STORport drivers? If so, do you have the latest STORport hotfix (at least KB943545)?

Regards,
Stephen
Gilbert Plouffe
Advisor

Re: FC shared tapes devices disapearing

First thank you for taking time to respond.
1. Randomly servers (not all servers at the same time) are losing all the devices. Also it could be anytime during the day or night, busy or not.
2. We used HP brand (Emulex LP9002 AD167A)
3. Tapes devices are directly connect on DCX and 48000.
4. Tapes current firmware and driver version (v4.0) & HBA driver and firmware are one version down but still supported by HP.
5. Storport driver are used
6. KB943545 issue do not demonstrate our current behaviour
Patrick Terlisten
Honored Contributor

Re: FC shared tapes devices disapearing

Hello,

you can try to lock port types and speed for the tapes at the director.

Regards,
Patrick
Best regards,
Patrick
Gilbert Plouffe
Advisor

Re: FC shared tapes devices disapearing

Hi

I did port lockdown on the director when the issue started, but no luck the problem did not go away

Torsten.
Acclaimed Contributor

Re: FC shared tapes devices disapearing

The HP branded storagetek libraries were using a special converter box to connect the SCSI tape drives to the SAN.
Does your library have something similar?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Gilbert Plouffe
Advisor

Re: FC shared tapes devices disapearing

Hi

No there is no converter or bridge between the FC switches

The Tapes are fabric devices (no loop) that are connected directly to the director.

thank you for your respond
Stephen Kebbell
Honored Contributor

Re: FC shared tapes devices disapearing

This is a stab in the dark, but has this any relevance?

http://www.emulex.com/support/viewArticle.jsp?docId=14

All our Windows Servers have Qlogic adapters, so I can't say if this will help, or if disk devices are adversely affected by these settings.
Try it on a non-production server first, if you have one.

Also, most storage vendors recommend a newer version of Storport.sys than the one that came with Win2003 SP2. The HP Driver release notes say that KB932755 should be installed.
http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=12169&prodSeriesId=3185350&swItem=co-83125-1&prodNameId=1833540&swEnvOID=1005&swLang=8&taskId=135&mode=4&idx=0

The KB Article I mentioned earlier is a newer version of storport than in KB932755.