HPE EVA Storage

Failover using multipathd on Linux 5.4

 
SOLVED
Go to solution
Tim Barton
Occasional Contributor

Failover using multipathd on Linux 5.4

Hi,

Since HP has told us we need to start using the native mulipathd and Qlogic HBA driver starting with Linux 5.3, I've been trying it on a test box running Oracle Enterprise Linux 5.4 64-bit, using two QLogic HBA's to an EVA 8100.

I've got multipathd working in theory, but it takes a long time to do a failover. I'll run an "ls -l" on a SAN-mouted LUN after disabling one of the two fiber ports that the server is connecting to, and it will take 1-2 minutes before the command works.

Is this expected behavior, or is there a way to make it shorter? I don't want to risk downtime if an Oracle database on one of these LUNs loses connectivity. I've played with some of the multipathd.conf settings without much luck.

Thanks.
6 REPLIES 6
Michael Leu
Honored Contributor
Solution

Re: Failover using multipathd on Linux 5.4

Hi Tim

The Release Notes of HP's own Device Mapper Enablement Kit has a section with the recommended device parameters:
http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?prodTypeId=12169&prodSeriesId=3559651&swItem=co-77761-1&prodNameId=3559652&swEnvOID=4035&swLang=13&taskId=135&mode=4&idx=0#Device_par_val

Scroll down a bit to see the QLogic HBA parameters. I think these also influence the failover time. They recommend "ql2xmaxqdepth=16 qlport_down_retry=10 ql2xloginretrycount=30" with the native QLogic drivers.
skt_skt
Honored Contributor

Re: Failover using multipathd on Linux 5.4

what are the default values you have for those parms? Even with default it should not take this much time.

I doubt if you need to tune at qlogic level as the communication between Multipath+array settings should take care of this
Tim Barton
Occasional Contributor

Re: Failover using multipathd on Linux 5.4

Have this in modprobe.conf:

options qla2xxx ql2xmaxqdepth=16 ql2xloginretrycount=30 qlport_down_retry=64


Tried taking the qlport_down_retry parameter, but that didn't help. I'll try changing it to 10
skt_skt
Honored Contributor

Re: Failover using multipathd on Linux 5.4

I have qlport_down_retry set to 30. Most of my servers has the hba/qlogic level fail over set to false and fail over is takan care by power path/array. But i have only a very few machines running with multipath.
Tim Barton
Occasional Contributor

Re: Failover using multipathd on Linux 5.4

Looks like those recommended settings did the trick. Failover response time is now just a few seconds, which should be fine.
Thanks!
skt_skt
Honored Contributor

Re: Failover using multipathd on Linux 5.4

did u tune all the three parms Tim mentioned? can u confirm what is the current values u have?