HPE EVA Storage

Firmware Compatibility in SAN Environment

 
Subentu
Frequent Advisor

Firmware Compatibility in SAN Environment

Hi Guys,

We have a SAN environment with following components:

EVA4000
xp128
3 Rx7620 servers
2 SAN switches

The current firmware version of the EVA controllers is 6.0.0.193
I want to upgrade it to 6.220

I want to find out weather the other components in the SAN will be compatible after the upgrade.

The current firmware versions of the other components are as below:

wbscsp01
Firmware info:
Firmware revision = 003.088
FP SWA driver revision: 1.18
IPMI is supported on this system.
BMC version: 7.8

wbscsp02
Firmware info:
Firmware revision = 003.088
FP SWA driver revision: 1.18
IPMI is supported on this system.
BMC version: 7.8

wbscsp03
Firmware info:
Firmware revision = 001.025
FP SWA driver revision: 1.18
IPMI is supported on this system.
BMC version: 6.12

SAN switch 1:
FOS Primary Partition 5.3.0c
FOS Secondary PArtition 5.3.0c

SAN switch 2:
FOS Primary Partition 5.3.0c
FOS Secondary Partition 5.3.0c

Thanks in advance
6 REPLIES 6
Johan Guldmyr
Honored Contributor

Re: Firmware Compatibility in SAN Environment

Hi!

I don't know about the xp or the rp-servers so can't say what version they should be at and if it's cmopatible.

But for the EVA and the SAN switches generally the latest one is the one that is supported.

6.0.0.193 - that is probably command view version and not EVA XCS Software Version.
Latest one for that is 9.2.1, see links below.
Please note that when upgrading from 6.x to 7.x+ you need to get a license.

For the SAN-switches what kind of switch is it?
Is this a 2gb switch? Generally for these the latest is 5.3.2c.
4gb generally go up to 6.2.x

http://h20272.www2.hp.com is a link to SPOCK that might be able to tell you more.

Command View EVA 9.2:
https://h20392.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=CommandViewEVA9.2

Command View EVA 9.2.1 Patch:
http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=US&swItem=co-84221-1

For the EVA4000 -

see http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?lang=en&cc=us&taskId=101&prodClassId=-1&contentType=SupportManual&docIndexId=64180&prodTypeId=12169&prodSeriesId=470490

and these documents:

"HP StorageWorks 4x00/6x00/8x00 Enterprise Virtual Array Updating Product Software Guide (XCS 6.220) (5697-0459, April 2010)"

"HP StorageWorks 4x00/6x00/8x00 Enterprise Virtual Array release notes (XCS 6.220) (5697-8035, April 2009)"

"HP StorageWorks Enterprise Virtual Array Compatibility Reference (5697-0465, April 2010)"
Subentu
Frequent Advisor

Re: Firmware Compatibility in SAN Environment

Correction:

Firmware version of the controller is 6.000, not 6.0.0.193 as I mentioned.
Torsten.
Acclaimed Contributor

Re: Firmware Compatibility in SAN Environment

I don't know what switch models do you have, but current versions are 6.2.x and 6.3.x.

For the rx servers please logon to MP and run

MP:CM> sysrev

for the XP please discuss this with HP, because you cannot get these firmware bits.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Torsten.
Acclaimed Contributor

Re: Firmware Compatibility in SAN Environment

See also SPOCK:

http://www.hp/com/storage/spock

http://h20272.www2.hp.com/

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Chris Rasmussen [FAU]
Frequent Advisor

Re: Firmware Compatibility in SAN Environment

Hi,

Did you find out the answers you wanted? I'm in the same situation and have everything I need except for FOS compatibility.

I've got the HP StorageWorks EVA Compatibility Reference but it just says to use SPOCK for host connectivity information. I'm specifically trying to make sure the latest FOS is compatible with XCS 6.22, though (the customer is asking for proof from the vendor).

Any info appreciated.
Subentu
Frequent Advisor

Re: Firmware Compatibility in SAN Environment

Hi

I did not had to upgrade the firmware in the servers. Only the switch firmware had to be upgraded.

Hope this is helpful.