HPE EVA Storage

G Port Blues--any clues?

 
SOLVED
Go to solution
Chris Vail
Honored Contributor

G Port Blues--any clues?

I'm trying to connect an A500/11.11 to a Brocade Silkworm 3800, with a HP 5158A Tachyon card. I've installed PHSS_28509 and rebooted. The problem remains: the 3800 Name Server shows that port to be a G port--and occasionally switches to U port, but more often than not doesn't show an entry at all for that port number.
It looks like the HP system is not accomplishing the flogi/plogi process. It should show it as an N port. I've swapped cables, with the same result. All LED's on both ends look good. Here's the output from switchshow:
(the A500 is on Port 2)
--------------------------------------
admin> switchshow
switchName: Poseidon
switchType: 9.1
switchState: Online
switchRole: Principal
switchDomain: 102
switchId: fffc66
switchWwn: 10:00:00:60:69:50:12:98
switchBeacon: OFF
port 0: id N1 Online F-Port 50:06:0b:00:00:13:fc:40
port 1: id N2 Online F-Port 10:00:00:00:c9:27:2f:2d
port 2: id N1 Online G-Port
port 3: id N1 Online F-Port 50:05:08:b3:00:30:01:3d
port 4: id N1 Online L-Port 15 public
port 5: id N1 Online F-Port 50:06:0b:00:00:07:37:a2
port 6: -- N2 No_Module
port 7: id N1 Online G-Port
port 8: id N1 Online G-Port
port 9: id N2 Online L-Port 1 public
port 10: -- N2 No_Module
port 11: -- N2 No_Module
port 12: -- N2 No_Module
port 13: -- N2 No_Module
port 14: -- N2 No_Module
port 15: -- N2 No_Module
--------------------------------------
Also, if I could get some clues as to why ports 7 & 8 also show as G ports, t'would be a wonderment.
Since this is Easter week, I'm handing out LOTS of bunnies........

Chris
9 REPLIES 9
Stuart Urquhart
Frequent Advisor

Re: G Port Blues--any clues?

Doc ID 3100527126 implies (tho' it's for 11.00), you may need to disable QL and SCSI compatible mode on the brocade
Craig_83
Frequent Advisor
Solution

Re: G Port Blues--any clues?

Hi Chris,

What version of the Fabric OS are you running? We had a similar problem and after talking to Brocade, the solution was to upgrade to v3.1.1b. After the upgrade the port types were then correct.

Craig
Chris Vail
Honored Contributor

Re: G Port Blues--any clues?

Thanks Craig! The OS Version is 3.0, and I'll try upgrading ASAP. There's a big bunny waiting for you.


Chris
Uwe Zessin
Honored Contributor

Re: G Port Blues--any clues?

I have seen such 'G Port blues' (I like that name - can I borrow it from time to time? ;-) with some AlphaServers, too. I could not upgrade the firmware, but a portDisable/PortEnable sequence helped in the end.
.
Chris Vail
Honored Contributor

Re: G Port Blues--any clues?

Uwe, the nice people at Brocade sent me the firmware upgrade without charge, even though we didn't have a support contract with them. If yours is also the 3800, email me privately and I'll reply with a copy of the file.

The upgrade worked famously. I got the damn thing zoned after 5 days of trying.

We Wizards gotta stick together.



Chris
Uwe Zessin
Honored Contributor

Re: G Port Blues--any clues?

Hello Chris.
Thank you for your generous offer. The problem has already been fixed - I sometimes hold back upgrades for testing with older equipment.
.
Craig_83
Frequent Advisor

Re: G Port Blues--any clues?

Hi Chris,

Glad to hear you got the upgrade for your 3800. Did it resolve your issue?

Craig
Michael Franklin
New Member

Re: G Port Blues--any clues?

Hey chris. I have the G-Port blues on a Silkworm 3800 which for me is brand new, but Brocade won't honor that fact. Is there any chance you can shoot me the rev?

Thanks for your consideration...


Mike
Haiver Bermon
Advisor

Re: G Port Blues--any clues?

Hello, I had this problem recently and I fixed, I have OV 7.5 on Win2003

1. Edit netmon.lrf file (OV_INSTALL/lrf) with this line

OVs_YES_START:ovtopmd,pmd,ovwdb:-P -k segRedux=true -k connectorL2Ports=legacy -k nonConnectorL2Ports=legacy -k migrateHsrpVirtualIP=true:OVs_WELL_BEHAVED:15:PAUSE

That line does that all port switches change to real status (green or red, not blue).

2. The switches that I wanted to full monitor, I selected and with de right botton of the mouse selected Symbol Propierties. In the Symbol Propierties window, Status Source option changed to Compoud(Propagate).

I hope this help you.

Haiver B.