HPE EVA Storage

High host port write latency on all EVA8400 ports when using a fixed path (no load balancing)

 
m_jamieson
Occasional Visitor

High host port write latency on all EVA8400 ports when using a fixed path (no load balancing)

Hello

 

Whilst testing changes and looking to improve performance on our EVA8400 I've noticed that when using a preferred path (set in DSM with ALB not enabled) during a big file copy write latency on host ports other than the preferrered one all increase. This is on both controllers ports.

 

I know ALB is recommended and do use ALB with SQST on our hosts which resolves this by balancing the writes over all host ports, but want to understand what is happening when using a single preferred path.

 

To test this I copy a large file from vDisk to vDisk on a single host with the preferred path set to the correct controller (which owns the vDisks). For this test I/O block size and queue depth were set to default so I'd expect the write latency to be higher, but only on the host port in use. Something is causing all host ports to be affected. I've checked that the correct host port is being used and no others show any I/O from the test host.

 

Setting an optimised I/O block size and queue depth (which I do normally) reduces this but I can still see the same result just on a smaller scale.

 

The only way to stop this is by changing from vRaid 5 to vRaid 1 (which I do on specific vDisks where required). Are the parity calculations causing the controllers to become overloaded and in turn increasing write latencies on all EVA host ports?

 

Thanks

2 REPLIES 2
Jan Soska
Honored Contributor

Re: High host port write latency on all EVA8400 ports when using a fixed path (no load balancing)

Hello,

there are 2 important think to check:

1) what types of drives are in your raid5 lun? (we see similar issues when using "fata" drives)

2) during testing period - don't you see higher latencies on all disk groups?

 

we saw similar behavior when doing sql updates on DB which was by mistake placed on raid 5 lun on fata disk group. Impact to whole EVA (eva6000) was tremendous. Latencies over 800ms ! on each disk gruop and host ports, we think caused by filling whole eva queue due miserable performance of fata drives.

Doing the same sql updates on different lun went smoothly without any impact to performance.(10K FC disks)

Lesson learned - never buy / use fata (except as place for storing movies :) )

 

Jan

m_jamieson
Occasional Visitor

Re: High host port write latency on all EVA8400 ports when using a fixed path (no load balancing)

Hi

 

We have a smaller FATA disk group but this was on our main FC disk group.

 

We get similar latencies to what you saw of 800+ on all host ports.

 

We don's see a big increase of latencies on the FC disk group (a few ms - not good but not in the hundreds) but I've not checked what happens at the same time on the FATA disk group. I will check this. The main impact is on all host port latencies.

 

 

Thanks