HPE EVA Storage

LUN Greater than 0 - Windows Setup failure

 
SOLVED
Go to solution
MWard
Advisor

LUN Greater than 0 - Windows Setup failure

I'm trying to setup a boot from SAN Win2k3 server with an Emulex 1150-LPe and am receiving the following error when trying to install to the SAN disk partition.

The hard disk containing the partition or free space you chose has a Logical Unit Number (LUN) greater than 0. Therefore, your computer's startup program cannot gain access to the disk. Setup cannot install Windows on this disk.

This is a Dell PowerEdge 1950, PERC 6i RAID controller.

Emulex card is set as top hard drive in boot order.

I've tried both Storport and SCSIPort drivers with equal results.

I've disabled the onboard RAID, etc. Has anyone seen this and figured out what the problem is?
10 REPLIES 10
Frantisek Kysela
Valued Contributor

Re: LUN Greater than 0 - Windows Setup failure

Hi,
because windows setup cannot use multipath, you need set up zoning for only one active path between server and array. After windows installation you can install MPIO and permit other paths.

Frantisek
If anything just cannot go wrong, it will anyway.
MWard
Advisor

Re: LUN Greater than 0 - Windows Setup failure

I am only using one active path. I've tried single path with each controller with the same results.

Mark Ramirez
New Member
Solution

Re: LUN Greater than 0 - Windows Setup failure

I just had the exact same issue just now on a DL385. I had the wrong lun selected in the HBA bios. Hope this helps.
MWard
Advisor

Re: LUN Greater than 0 - Windows Setup failure

I'm sorry I haven't posted the solution. I had fixed this a while back.. I also selected the wrong LUN in the HBA bios. Meaning that the disk was LUN 02 on the SAN, and I put it in as 01, instead of 02.

Thanks Mark for your reply.

Re: LUN Greater than 0 - Windows Setup failure

Hi Guys.
I have this exact same problem.

The Windows 2003 install says that I can't chose a LUN greater than 0.

The lowest LUN number I can select on my EVA is 0.

This is HP Bl460c G7 and Qlogic QMH2462.
I have other generations of this server and have no problems.

Please help me :)

Best regards
Christian

Re: LUN Greater than 0 - Windows Setup failure

Sorry. I ment that i cant select LUN 0 on the EVA.
Uwe Zessin
Honored Contributor

Re: LUN Greater than 0 - Windows Setup failure

LUN 0 on the EVA is a controller (SCSI type 12(10) device),
not a SCSI disk with storage capacity.
.

Re: LUN Greater than 0 - Windows Setup failure

Ok. But how do I get win2003 to understand that?
Proliant VMS San Mgrs
Frequent Advisor

Re: LUN Greater than 0 - Windows Setup failure

Christian, boot is through the BIOS. You have to properly configure any device which you want to appear in the "Boot Order" list.

For Emulex LPe1105, as on the BL460cG1, you have to hit E during the startup BIOS screen, and then go through the menu to set various options, including the LUN.

You need to have the machine powered on while you do the zoning (only 1 path, remember); and then you need to go into CVEVA and map a VDISK to a LUN; and then you go into the BIOS and enable that LUN for booting, but only through 1 path.

Once it's running, as others have said, you need to update the zoning to allow 4 paths; and then update the Emulex (or other adapter) BIOS to boot off any of the 4 paths.

With Emulex, you should really install HBAnywhere, which makes this so much easier, as you can even upgrade BIOS / Adapter firmware from the GUI (be careful doing that).

HTH,

Carl
Problems Solved