HPE EVA Storage

MSA 1000 Controller - HP ACU CLI issue

 
SOLVED
Go to solution
Jeff Arwood
Advisor

MSA 1000 Controller - HP ACU CLI issue

Hello I have attached the HP console cable to the MSA 1000 controller and the serial end to host server. I have ran the HP ACU CLI and issued the command "controller all show" all the system sees is the smart array 6i in slot 0 (embedded). I was hoping to access the msa controller and reset configuration in my attempt to troubleshoot fibre link issue that I have another thread open on. I am starting to believe there is something wrong with this controller for I also replaced all 14 old HP 72.GB drives with new HP 145 GB drives and the controller still shows old error messages about non compaq drives. Please advise
9 REPLIES 9
Johan Guldmyr
Honored Contributor

Re: MSA 1000 Controller - HP ACU CLI issue

Hey, if the ACU-CLI(or the ACU) does not display the MSA then you do not have contact between the server and the MSA controller.

Suggest that you try the serial interface and use hyperterm or another terminal emulator (not ACU-CLI) to connect to the MSA.

Do you only have one MSA1000 controller?

What does it say in the LCD-display?
What kind of fc-links do you have?
At the back of it, do you have 4, 6 or 8 ports? Like do you have the embedded SAN switch?
Then another thing you can do is to connect to the embedded SAN-switch (another serial port) and look in there, maybe there is zoning on the switch causing the connectivity issues.
Torsten.
Acclaimed Contributor

Re: MSA 1000 Controller - HP ACU CLI issue

For connection via serial cable you need to use a terminal emulator, e.g. putty with 19200 speed.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Clarete Riana
Valued Contributor

Re: MSA 1000 Controller - HP ACU CLI issue

Once you are connected to the MSA CLI, you can issue commands SHOW THIS_CONTROLLER, SHOW OTHER_CONTROLLER. These commands will give you the controller information. You can issue SHOW CONNECTIONS command and see if the WWPN of the corresponding fibre link that you are troubleshooting is visible.

For help on MSA CLI refer to the HP StorageWorks 1000/1500 Modular Smart array CLI user guide at the following location.

http://bizsupport.austin.hp.com/bc/docs/support/SupportManual/c01183955/c01183955.pdf
cnb
Honored Contributor

Re: MSA 1000 Controller - HP ACU CLI issue

Jeff,

As Torsten stated you'll need to use putty or Hyperterm to get to the CLI of the MSA.

If the system isn't seeing the array then you'll need to use the MSA (RS-232 to RJ45z) cable (Compaq/HP # 259992-001) to communicate directly with the MSA.

Once connected to the MSA1000 RJ45z port on the MSA1000 front bezel, issue and capture the "show tech_support" command and post the results.

Rgds,
Jeff Arwood
Advisor

Re: MSA 1000 Controller - HP ACU CLI issue

What is the best way to update the firmware on the controller?

I replaced the HBA in the server, now the web acu works so I utilized it instead. Still looking at how to make putty work since Hyperterminal is no longer available on newer OS
Uwe Zessin
Honored Contributor

Re: MSA 1000 Controller - HP ACU CLI issue

The support pages should offer update utilities to flash the controllers 'in-band' (over the Fibre Channel link).
What is the problem with Putty? Did you specify 19200 as the line speed?
.
Jeff Arwood
Advisor

Re: MSA 1000 Controller - HP ACU CLI issue

The problem with putty is I am new to it :)

Thanks again on the inband confirmation on how best to update firmware on controller.

Jeff Arwood
Advisor

Re: MSA 1000 Controller - HP ACU CLI issue

CBN,

I am a little confused now after reading you post. My understanding is I will need a terminal emulator running to communicate connected to the msa via the cable directly attached to the MSA for the CLI commands to work?

Is there anyway to communicate with the MSA without the CLI just directly connected via a cable and laptop?

Jeff,

As Torsten stated you'll need to use putty or Hyperterm to get to the CLI of the MSA.

If the system isn't seeing the array then you'll need to use the MSA (RS-232 to RJ45z) cable (Compaq/HP # 259992-001) to communicate directly with the MSA.

Once connected to the MSA1000 RJ45z port on the MSA1000 front bezel, issue and capture the "show tech_support" command and post the results.
cnb
Honored Contributor
Solution

Re: MSA 1000 Controller - HP ACU CLI issue

Jeff,

That was before you had any other means of communicating with it. Since the fibre issue is resolved you have some different options now.

See this manual (Chapter 3):

http://bizsupport2.austin.hp.com/bc/docs/support/SupportManual/c00800933/c00800933.pdf

Rgds,