HPE EVA Storage

MSA 1000 Embedded SAN Switch 2/8

 
Greg Frase
Occasional Contributor

MSA 1000 Embedded SAN Switch 2/8

I have to reset this switch or reload it with the FOS 3.x.x firmware. Some how some one loaded FOS 5.3.2 and it stops the boot process at VXWORKS BOOT and gives flash write errors. Does anyone have a document or path I can try?
10 REPLIES 10
Emad Omar
Regular Advisor

Re: MSA 1000 Embedded SAN Switch 2/8

Dear Greg,
Do you have one controller or two??
If you have two controllers, then I recommend to swap these two controllers. Try to update the FW on the primary, then cloning will be start on the secondary if the FW on the primery completed successfully.

Let me know if this help.
IBaltay
Honored Contributor

Re: MSA 1000 Embedded SAN Switch 2/8

Hi,
5.3.2 is not compatible with the embedded 2/8 and 3.2.1c should be reaplied via e.g. ssh/telnet firmwaredownload (to downgrade it to this version),
try firmwareshow to see which versions of firmware are active ....
the pain is one part of the reality
Uwe Zessin
Honored Contributor

Re: MSA 1000 Embedded SAN Switch 2/8

Emad, the problem is with the embedded switch, not the MSA1000 controller module.

Greg,
if you press "?" at the "[VxWorks Boot]: " prompt, should get a menue. One of the entries allows a network boot. I have never tried it and don't know if it works with the flash image, but I think it is worth a try.
.
Greg Frase
Occasional Contributor

Re: MSA 1000 Embedded SAN Switch 2/8

I do get a menu when I type ? at the vxworks boot prompt and I have tried just about all of those commands. Is there a way to force the switch to accept an upload of the FOS 3.x.x? Is there a document or a procedure to do this?
marsh_1
Honored Contributor

Re: MSA 1000 Embedded SAN Switch 2/8

hi,

what options did you try ? and what were the results/errors ?

computailor
New Member

Re: MSA 1000 Embedded SAN Switch 2/8

We have the same problem as Greg.
Only get the VxWorks prompt and load/download of v3.2.1c from flash/net unsuccessful. Have tried all options available.
Output from serial line:

[VxWorks Boot]: !
Boot 0: booting from flash 0
Boot 0: 110336+6408
Boot 0: uncompressed - loading text and data
Boot 0: starting at 0x10030000...


Loading compressed image from flash...
Boot 0: booting from flash 0
Boot 0: 110336+6408
Boot 0: compressed
Boot 0: uncompressing 3164827 bytes from flash at 0xc005c858
Boot 0: jumping to RAM at 0x10400000

Attaching network interface fei0... Committing configuration...flashBlockErase: timeout at 0xc0000000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0000000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0000000, csr = 0xff7f
.......
flashWrite: failed - retrying
flashWrite: giving up
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
.......
flashWrite: failed - retrying
flashWrite: giving up
EMB SCN Config change
done.
sysEnetAddrGet: Enet Addr invalid
sys557: failed to get the Ethernet MAC address!
failed: errno = 0x5.

efwHookAdd: Added Ethernet Hook

Adding 12309 symbols for standalone.

Trace cleared
sysNvRamGet: NvRam not valid - using default
flashBlockErase: timeout at 0xc0000000, csr = 0xff7f
flashWrite: failed - retrying
........
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashWrite: giving up
EMB SCN BootLine change
Model: 18
flashBlockErase: timeout at 0xc0f60000, csr = 0xff7f
flashBlockErase: timeout at 0xc0f60000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0f60000, csr = 0xff7f
flashWrite: failed - retrying
flashWrite: succeeded after 2 tries
setting passwd to defaults
flashBlockErase: timeout at 0xc0000000, csr = 0xff7f
flashWrite: failed - retrying
......
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashWrite: giving up
sysEnetAddrGet: Enet Addr invalid
Nov 13 15:13:14
Panic: INCONSISTENT - no enet addr

Ba

BootProm rev 3.5
Switch model 13, revision 2
Running DRAM Test .... passed

First stage boot
g0= 0x00000202 g1= 0x00000000 g2= 0x00000000 g3= 0x00000000
g4= 0x00000000 g5= 0x00000000 g6= 0x00000000 g7= 0x00000000
uncompressing ROM to RAM
jumping to RAM at 0x10c00000

VxWorks System Boot

Copyright 1984-1994 Wind River Systems, Inc.

CPU: i960
Version: 5.3.1
BSP version: 1.0
Creation date: Mon Jul 8 18:35:34 PDT 2002

sysNvRamGet: NvRam not valid - using default
flashBlockErase: timeout at 0xc0000000, csr = 0xff7f
flashWrite: failed - retrying
flashWrite: succeeded after 1 tries
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashWrite: succeeded after 4 tries

sysEnetAddrGet: Enet Addr invalid

No Ethernet address
Use 'N' command to set the Ethernet address
........
[VxWorks Boot]: N
sysEnetAddrGet: Enet Addr invalid
Current Ethernet Address is: 60:4f:ff:11:f0:4f
Modify only the last 3 bytes (board unique portion) of Ethernet Address.
The first 3 bytes are fixed at manufacturer's default address block.
00- 00
60- 60
69- 69
11- ca
f0- 77
4f- 8c

flashBlockErase: timeout at 0xc0000000, csr = 0xff7f
flashWrite: failed - retrying
flashWrite: succeeded after 1 tries
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashWrite: succeeded after 4 tries
New Ethernet Address is: 00:60:69:ca:77:8c
[VxWorks Boot]:
-------------------------------------------
About the same happens if I change boot parameters to download via ftp (download is successful).
The new ethernet hw-address is the original from old config backup (do not know where it has got the 11:f0:4f -address). Tried with both.
Are there any undocumented commands?
Telnet is unavailabe.
Any way to boot from secondary flash?
Is it possible to flash via serial line (X-modem)?

Any help would be very appreciated!

TechHelp24
Frequent Advisor

Re: MSA 1000 Embedded SAN Switch 2/8

is long time ago.... You can start the switch from FTP which contain the firmware, then try whit "firmwaredownload" to install the firmware now.

MSA1000 switch is a Embedded Brocade 3000, and is supported only by FabOS 3.x
sysmgr
New Member

Re: MSA 1000 Embedded SAN Switch 2/8

hi,dear masters
We have the same problem as Greg and computailor.
But after change Ethernet Address

[VxWorks Boot]: N
sysEnetAddrGet: Enet Addr invalid
Current Ethernet Address is: 60:4f:ff:11:f0:4f
Modify only the last 3 bytes (board unique portion) of Ethernet Address.
The first 3 bytes are fixed at manufacturer's default address block.
00- 00
60- 60
69- 69
11- ff
f0- ff
4f- ff

flashBlockErase: timeout at 0xc0000000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0000000, csr = 0xff7f
flashWrite: failed - retrying
flashWrite: succeeded after 2 tries
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashWrite: succeeded after 4 tries
New Ethernet Address is: 00:60:69:ff:ff:ff


( also change to 60:4f:ff:11:f0:4f and to 60:4f:ff:ca:5f:55)

and change boot parameters :
[VxWorks Boot]: p

boot device : fei
processor number : 0
host name : winnt
file name : c:\0sysmgr_ftp\v32.1c
inet on ethernet (e) : 172.18.0.141:ffff0000
host inet (h) : 172.18.10.198
gateway inet (g) : 172.18.2.56
user (u) : sysmgr
ftp password (pw) : anakonda
flags (f) : 0x0
target name (tn) : -switch1

and boot as

[VxWorks Boot]: @

boot device : fei
processor number : 0
host name : winnt
file name : c:\0sysmgr_ftp\v32.1c
inet on ethernet (e) : 172.18.0.141:ffff0000
host inet (h) : 172.18.10.198
gateway inet (g) : 172.18.2.56
user (u) : sysmgr
ftp password (pw) : anakonda
flags (f) : 0x0
target name (tn) : -switch1

Attaching network interface fei0... done.
Attaching network interface lo0... done.
winnt is alive
Loading... 110336 + 6408 + 131212
Starting at 0x10030310...


Loading compressed image from flash...
Boot 0: booting from flash 0
Boot 0: 110336+6408
Boot 0: compressed
Boot 0: uncompressing 3155323 bytes from flash at 0xc005c858
Boot 0: jumping to RAM at 0x10400000

Attaching network interface fei0... Committing configuration...flashBlockErase:
timeout at 0xc0000000, csr = 0xff7f
...
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashWrite: giving up
EMB SCN Config change
done.
sysEnetAddrGet: Enet Addr invalid
sys557: failed to get the Ethernet MAC address!
failed: errno = 0x5.

efwHookAdd: Added Ethernet Hook

Adding 12287 symbols for standalone.

Trace cleared
sysNvRamGet: NvRam not valid - using default

flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashWrite: giving up
EMB SCN BootLine change
Model: 18
setting passwd to defaults
...
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashWrite: giving up
sysEnetAddrGet: Enet Addr invalid
Feb 7 03:01:28
Panic: INCONSISTENT - no enet addr

Ba


BootProm rev 3.5
Switch model 13, revision 2
Running DRAM Test .... passed


First stage boot
g0= 0x00000202 g1= 0x00000000 g2= 0x00000000 g3= 0x00000000
g4= 0x00000000 g5= 0x00000000 g6= 0x00000000 g7= 0x00000000
uncompressing ROM to RAM
jumping to RAM at 0x10c00000

VxWorks System Boot


Copyright 1984-1994 Wind River Systems, Inc.


CPU: i960
Version: 5.3.1
BSP version: 1.0
Creation date: Mon Jul 8 18:35:34 PDT 2002

sysNvRamGet: NvRam not valid - using default

flashBlockErase: timeout at 0xc0000000, csr = 0xff7f
flashWrite: failed - retrying
flashWrite: succeeded after 1 tries
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashBlockErase: timeout at 0xc0800000, csr = 0xff7f
flashWrite: failed - retrying
flashWrite: succeeded after 3 tries


sysEnetAddrGet: Enet Addr invalid

No Ethernet address
Use 'N' command to set the Ethernet address

==============
[VxWorks Boot]: p

boot device : fei
processor number : 0
host name : host
file name : /usr/switch/firmware
inet on ethernet (e) : 10.0.0.0
user (u) : user
flags (f) : 0x0
target name (tn) : switch
=====
we can't load FabOS !!!!!
what options did you try ?
P.S.
c:\0sysmgr_ftp\v32.1c - firmware for MSA 1000 SAN switch 2/8 from HP site(but renamed from v3.2.1c)
computailor
New Member

Re: MSA 1000 Embedded SAN Switch 2/8

Hi,
I think I tired all options available, still getting falsh errors and looses the Enet hw address.

I bought a refurbished replacement switch (got it last week) and it works fine.
If you do this, do not download the old switch's configuration to the new without double checking the configuration (I messed up the licenses. Fortunately I had them on paper for recovery).

After getting it up and running I put the old switch in the scondary slot. Same errors.
I was hoping that the new working primary switch would had corrected the old one (replication primary->secondary) but nope.

Flash memory error/corruption ?

We now have three quite identical diagnoses!
Anybody, any suggestions?