HPE EVA Storage

MSA 2012fc Dual - send e-mail problem

 
Ray Siripan
Occasional Advisor

MSA 2012fc Dual - send e-mail problem

Hi All,
I'm trying to setup the e-mail notification and receiveing "Error sending e-mail" everytime when click on "Test Send e-mail"

I have put a correct snmp relay (IP Address) and it can reach from the controller (ping success), check the smtp relay server and it definately can send mail, also put a correct domain, sender and all 4 receivers.

Any idea what went wrong?
thanks
5 REPLIES 5
Cameorn Steadman
New Member

Re: MSA 2012fc Dual - send e-mail problem

I found a workaround. It appears that the way the MSA sends its "RCPT TO:" message doesn't comply with RFC821 so some SMTP servers may discard the message.

I found that by putting the destination email address in angle brackets - i.e. my emails started working.

HP should fix this problem, since the RFC clearly states that "RCPT TO:" and "MAIL FROM:" addresses need to be in angle brackets.

Hope this helps.
Filip Ons
New Member

Re: MSA 2012fc Dual - send e-mail problem

Have you ever found a solution to this problem?
Because putting the receiving email between brackets does not work with me.
Ammad
Occasional Advisor

Re: MSA 2012fc Dual - send e-mail problem

Manage -> Event Notification -> email configuration

Email Address - user@example.com
Email Comment - Oracle Storage MSA 2000 Fc
Mail Server - 192.168.0.10
Domain Name - example.com
Sender Name - alert
Email Notification Enable - Enabled


IP address of SMTP server e.g 192.168.0.10
Sender Name is alert without, this should be exist on your email server.
setadini
New Member

Re: MSA 2012fc Dual - send e-mail problem

I have the same problem. On many MSA2000 (iscsi and fc) it works but on a specific one it gives the error (same firmware and similar config but on different customer).
Is there a way to debug this message?

Thank you
niconl
Occasional Visitor

Re: MSA 2012fc Dual - send e-mail problem

I had the same error. In my case the domainname was causing the send e-mail error. First I entered mydomainname.local, after changing that to mydomainname.com, used for mx, the MSA2012 succesfully started sending e-mails.