HPE EVA Storage

MSA1500 CS - Code 271 - Failed Logical Drives

 
SOLVED
Go to solution
Borg8472
Frequent Advisor

MSA1500 CS - Code 271 - Failed Logical Drives

Powered-On my disk arrays and MSA1500 CS properly but ESX host servers halt loading "vsd-mount". Upon review of attached storage via ACU, I found that 9 out of 12 logical drives failed with error "Logical drive 3 (410.2 GB, RAID5) has failed and cannot be used. All data on this logical drive has been lost. Configuration changes to this logical drive are not allowed until this problem is corrected. also, if your controller supports Expansion, Extension, or migration, these ...". See attached snapshot.

I do care about data on the logical drives and do not have a valid backup. Is it possible to recovery from this error without losing data? If Yes, how?

I would like to call HP Technical Support on this but the MSA1500 CS is no longer under warranty.
10 REPLIES 10
Víctor Cespón
Honored Contributor

Re: MSA1500 CS - Code 271 - Failed Logical Drives

What do have in common the Arrays C, D, E, F, I, J, K, L and M?

The logical unit is RAID 5 so you must have at least 2 disks failed.

Maybe you have an MSA20 or MSA30 disconnected or failed and there are lot of disks missing.
Borg8472
Frequent Advisor

Re: MSA1500 CS - Code 271 - Failed Logical Drives

Looks like the only commonality amongst the logical drives is the FC SAN Switch, a (StorageWorks SAN Switch 2/4V). All 4 MSA60 storage arrays are present, online and all disks and MSA controller reporting no failures. All drives and disk arrays have green LEDs, no reds and no failures on MSA1500 CS Controller display.
Borg8472
Frequent Advisor

Re: MSA1500 CS - Code 271 - Failed Logical Drives

Upon further review I did find the logical drive failure notifications in the MSA1500 CS display panel by scrolling through the messages/notifications.

I still need to retain the content of the failed logical drives if at all possible.

Any help is greatly appreciated!

Thanks!
Borg8472
Frequent Advisor

Re: MSA1500 CS - Code 271 - Failed Logical Drives

I re-seated the MSA controllers, power supplies, I/O modules and SFP Optical Transceivers. This allowed ESX servers to boot up all the way and have access to non-failed logical drives. The failed logical drives are still not accessible.

The problem now is that HP ACU can no longer communicate with the MSA, it just times out.

I reinstalled PSP, plus uninstalled and reinstalled ACU, plus ACU CLI. I have reset HBA QLA2312F back to factory default settings and gather that the latest QLA2312f HBA Windows driver comes from the PSP, which is up-to-date.

I just want ACU to re-gain access to the failed logical drives, so that I can accept the failure and re-enable the failed drives to move forward.
Prashant (I am Back)
Honored Contributor
Solution

Re: MSA1500 CS - Code 271 - Failed Logical Drives

hi there,

you can give me the error message when you checking the msa through ACU.

Or

You can use CLI port and use the command.
accept units.
accept unit (unit no)
This is as good as ACU

Prashant S.
Nothing is impossible
Borg8472
Frequent Advisor

Re: MSA1500 CS - Code 271 - Failed Logical Drives

My attached server (DL360 G4) took over 1.5 hrs to boot while being connected to SAN/Switch/MSA. I disconnect FC cable in order to allow the server to complete its boot process. The error in EventViewer is "The driver detected a controller error on \Device\Harddisk2".

I am looking into seeing what I can do at the ACU CLI level to try to resolve.

Thanks for the suggestion!
Borg8472
Frequent Advisor

Re: MSA1500 CS - Code 271 - Failed Logical Drives

Yes, the Accept Units command helped. This command looks like it re-enable 4 out of the 8 logical drives. Upon issuing the Show Eventlog command, there are still issues with the last 4 logical drives. I am willing to just delete and re-create them if I can re-gain access to them via CLI command prompt. When the MSA boots all the way up, it says Scanning for Devices, then goes away after 10 minutes and does not give me a CLI command prompt. Pressing the < or > buttons on the display does not display any messages. I have re-seated MSA components again, but it had no effect.

Suggests are welcome!
Borg8472
Frequent Advisor

Re: MSA1500 CS - Code 271 - Failed Logical Drives

I was able to re-gain access to ACU CLI by disconnecting the SCSI I/O modules. The MSA is currently in a locked state, such that no matter what command I issue, it pops the below message "ACU Lock state is currently Active. Locked by WWN xxx". Attached is a snap-shot of the error message. Researching how to get out of this locked state.
Borg8472
Frequent Advisor

Re: MSA1500 CS - Code 271 - Failed Logical Drives

I was able to get around the locked state at the CLI level by issuing command "Override ACULock On". This allowed me to run a Show Tech_Support command. Attached is a copy of the Tech_Support report. Is the problem, I need to assign/correct the Profile Names?