HPE EVA Storage

MSA1500 HP-UX Connectivity

 
shashi kanth
Super Advisor

MSA1500 HP-UX Connectivity

I have made a direct connection between MSA1500 controllers to one HP-UX11iv2 IA box.

I enabled FC-AL hard addressing, and i created a LUN with HP-UX host mode.

On the HP-UX box, i am able to see the LUN. But i am not able see the controller.

I installed OnlineDiag and hpacucli depot.

#/opt/compaq/hpacucli/bld/hpacucli controller all show

Error: No controllers detected.

#ioscan -fnkC disk | grep MSA
disk 8 0/2/1/0.8.0.1.0.0.0 sdisk CLAIMED DEVICE HP MSA VOLUME
disk 10 0/2/1/0.8.0.1.0.0.1 sdisk CLAIMED DEVICE HP MSA VOLUME
disk 9 0/2/1/1.8.0.1.0.0.0 sdisk CLAIMED DEVICE HP MSA VOLUME
disk 11 0/2/1/1.8.0.1.0.0.1 sdisk CLAIMED DEVICE HP MSA VOLUME


Please any one tell me, why HP-UX box not able to see the MSA Controllers ?

Thanks.
3 REPLIES 3
Torsten.
Acclaimed Contributor

Re: MSA1500 HP-UX Connectivity

I see them on a test system:

ext_bus 1 0/3/0/0/0/0.4.0.255.0 fcd_vbus CLAIMED INTERFA
CE FCP Device Interface
target 1 0/3/0/0/0/0.4.0.255.0.0 tgt CLAIMED DEVICE

ctl 0 0/3/0/0/0/0.4.0.255.0.0.0 sctl CLAIMED DEVICE
HP MSA CONTROLLER
/dev/rscsi/c1t0d0


Could you please post a full "ioscan -fn", please?


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
shashi kanth
Super Advisor

Re: MSA1500 HP-UX Connectivity

I too see them with ioscan

#ioscan -fn | grep CONTROLLER
ctl 6 0/2/1/0.8.0.255.0.1.0 sctl CLAIMED DEVICE HP MSA CONTROLLER
ctl 5 0/2/1/1.8.0.255.0.1.0 sctl CLAIMED DEVICE HP MSA CONTROLLER


BUT

#/opt/compaq/hpacucli/bld/hpacucli rescan
#/opt/compaq/hpacucli/bld/hpacucli controller all show

Error: No controllers detected.
Torsten.
Acclaimed Contributor

Re: MSA1500 HP-UX Connectivity

I never worked with this CLI, but do you see a "rscsi" device file in ioscan? Did you try a "show target" from CLI?

Refer to the readme file more more help.




From the readme I have (maybe a bit old):

Additional Notes
----------------
1. Create connection using CLI with profile as HP and reboot the host before running ACU CLI.
CLI> add connection WWPN=xxxxxxxx-xxxxxxxx profile=HP
...



Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!