MSA1500 Performance

 
Dennis Hou
New Member

MSA1500 Performance

We've had two MSA1500's for quite sometime. Just recently, we started trying out different VM options and started experiencing high I/O wait on database boxes.

All our blade servers (24 of them) are booting from SAN - roughly 10 off one MSA1500, and 14 off the other.

A snippet of performance monitoring from our Dev/Test SAN shows as follows - is the AvQDep the queue depth? And does that look normal to be so high for some LUN's?


CLI-2> show perf

Sample interval: 5921.1s
Structure version: 101
% CPU utilization: 45%
Command count: 1916273
Avg Command Latency: 1.78ms
% Time Active Reqs: 31.5%
Max Outst Cmd Lists: 44
Logical Req Count: 1916273
Avg Free Phys Reqs: 1551
Avg Free Log. Reqs: 767
Avg Free Xbuf Sects: 0
Avg Lrgst Avail Xb S: 0
Avg Free CPU DRAM KB: 0
Max DMA Xfer Q Depth: 0
% Time DMA Xfr Stall: 0.0%
Avg Locked Stripes: 0
Avg Stripes Waiting: 0
Avg Completions/Sec: 323.6
Avg Log Req Comp/Sec: 323.6

Logical volume data: (All values in hex except Vol and AvQDep)
Vol LWrites LReads AvQDep CHits CMiss RACount LSectRd LSectWr
1 CACB 3B 13467 1 3A 0 6E8 1A6AF8
4 C01C A3D 26869 0 A3D 0 281D0 1C5F00
6 26E9F 4238D 27380 3CE5F 552E 0 661675 345FD0
9 BECA 0 25102 0 0 0 0 1A56A8
10 103 C9 12 0 C9 0 648 D80
13 0 0 0 0 0 0 0 0
15 3D30 2ED5 20 2BA1 334 0 202058 5EFE8
17 22E4D 2A76C 7269 231EB 758E 0 198A6B 30E036
19 0 0 0 0 0 0 0 0
21 24 75 0 4A 46 0 B10 24
25 0 0 0 0 0 0 0 0
27 1F44C A00B2 802 946E 96C44 0 76F8542 11F5C2
29 DBA2 15DD0 28 15A9C 334 0 16FE02 62053
30 0 0 0 0 0 0 0 0
31 3C18 2E2F 18 2B92 29D 0 200268 5EF90
1 REPLY 1
Matt McElreath
Occasional Advisor

Re: MSA1500 Performance

Did you ever figure this out. We are seeing big performance issues on one of our DB servers, specifically with Disk reads.