HPE EVA Storage

MSA2000sa + P700m Raid controller = Drives not shown?

 
Kevin De Schrijver
Occasional Contributor

MSA2000sa + P700m Raid controller = Drives not shown?

The setup:

MSA200SA G2 connect to a C7000 blade enclosure through 2 BLswitches
OS: Windows 2008 R2

I read through the manual, racked and cabled the MSA accordingly. There's plenty of manuals on this part.

I also set up the SMU, created a few vDisks and volumes, added a test host and mapped the volume to the host. Plenty of documentation on that part as well.

If I check the test host ACU it tells me there are no LUN's visible. Obviously I'm doing something stupid wrong here. Unfortunately I can't seem to locate any manual or guide on how to actually connect the Host to the volume created on the MSA2000sa. Anyone out there with some info?




p.s. I have learned that Multipath wont work on 2008 R2 (Yay!) along my search but I haven't activated any multipath software or settings yet so that shouldn't be an issue.

I also activated the following just to be sure:
http://bizsupport.austin.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01589395〈=en&cc=us&taskId=101&prodSeriesId=3758996&prodTypeId=12169&docLang=en
3 REPLIES 3
Greybeard
Esteemed Contributor

Re: MSA2000sa + P700m Raid controller = Drives not shown?

How have you connected a direct attach SAS unit to two switches? Is this an sa or an FC model. if FC and using 2 switches you may have triggered domain zoning, log into a switch and see if you have empty zones. The SAN and servers need to be in the same zone :)
_________________________________________________
How to assign points on this new forum? Click the Kudos Star!
Kevin De Schrijver
Occasional Contributor

Re: MSA2000sa + P700m Raid controller = Drives not shown?

Found the solution to my own stupidity. Most important notes: you need to change the registry so that your RAID controller becomes a SAS controller AND...your disks aren't visible in the HP ACU and that's the way the cookie crumbles. You're not supposed to use it for this setup.

This article explains it all fairly well. Just a small note on step 4. You can discover your device ID through the MS MPIO tool in case it's a slightly different device then the one in the example:

http://forums13.itrc.hp.com/service/forums/questionanswer.do?admit=109447627+1285322252355+28353475&threadId=1416805
Kevin De Schrijver
Occasional Contributor

Re: MSA2000sa + P700m Raid controller = Drives not shown?

Solution above