HPE EVA Storage

Making ports N_Port instead of NL_Port

 
SOLVED
Go to solution
Jeff_Traigle
Honored Contributor

Making ports N_Port instead of NL_Port

I've fumbled around with this enough so could use some help. The situation is as follows:

We have 2 HP-UX 11.11 systems attached to 2 Brocade switches connected to 2 VA7100s. One host can see both VAs. The other host can only see one. I figured out yesterday that one of the switches is configured as an arbitrated loop (NL_Port shows from fcmsutil and L-Port shows with switchShow on the Brocade). The other switch is configured as Direct Fabric Attach (N_Port from fcmsutil and F-Port with switchShow).

So, I figure I need to get the second switch also configured as Direct Fabric Attach, but have no clue how. I found the portCfgLport command on the Brocade, but it reports the ports are not locked as L-Ports. (The help screen for the command also made it sound like this is controlled from the HBA of the connected host since, even when locked, it says the port will respond to a host to be a non-L-Port.) I didn't see anything that jumped out at me in the fcmsutil man page how I would set this either though.

So, where does this get set and how do I change it?
--
Jeff Traigle
12 REPLIES 12
MitVongNam
Frequent Advisor

Re: Making ports N_Port instead of NL_Port

I am seeing options of L/F/E port to be assigned in Switch Admin /Ports tabs. Of course, it is not CLI. Regard;

I am also interested how to do it at CLI. I am seeing the same command in Fabric OS v4.x
Jeff_Traigle
Honored Contributor

Re: Making ports N_Port instead of NL_Port

Must be a different switch or different OS from what I have. I connected via the web interface. The only port configuration options I see are to enable/disable. Mine are SilkWorm 2800s. Don't know the OS version on them. (How do you tell?)
--
Jeff Traigle
Jeff_Traigle
Honored Contributor

Re: Making ports N_Port instead of NL_Port

Oh. Fabric OS Release a2.4.1. Conveniently displayed in the telnet login banner. :)
--
Jeff Traigle
Bernd Reize
Trusted Contributor

Re: Making ports N_Port instead of NL_Port

brocade switches have a arbitrated loop feature called quickloop, this sets the whole switch into loop mode.
You can check with "qlshow" if this is the case with your switch and disable it with "qldisable" (global for the switch or with qlportdisable on single ports)
m saravanan
Valued Contributor

Re: Making ports N_Port instead of NL_Port

Greetings...!
There are two possibilities:
1. The HBA might support Loop configuraton only. This you can check it with the Hardware vendors (HBA supported configuration).

2. The port might locked as a L_PORT. To check the port initialization, login to the switch through CLI & enter the command,
"portcfgchow

For Ex:
Switch1:admin> portshow 1
portName:
portHealth: No License
Authentication: None
portFlags: 0x223805b portLbMod: 0x0 PRESENT ACTIVE F_PORT G_PORT U_PORT LOGIN NOELP LED ACCEPT WAS_EPORT
portType: 4.1
portState: 1 Online
portPhys: 6 In_Sync
portScn: 6 F_Port
portRegs: 0x81010000
portData: 0x102cbb10
portId: 010100


Look at the output at the line starting "portFlags", wherein u can find the port initialization.

To check the ports locked as L-PORT, simply give command "portcfgLport" without any arguments.

If the port is set as L_PORT, try to set the port to defualt using,
"portcfgDefault" command.

Hope it will help you.

Thanks & Regds,
Saravanan
Jeff_Traigle
Honored Contributor

Re: Making ports N_Port instead of NL_Port

The switch is not in QuickLoop mode and the ports showing as L-Ports are in Fabric mode already according to qlportdisable.

I've included the output of switchshow and portshow below. sw3 is the problem. portcfglport only sets the value and trying to set it to 0 for ports 1 and 14 says they are already disabled. There is no portcfgdefault command... only a configDefault command, but that resets the whole switch to factory defaults and that seems rather drastic.

sw1:admin>switchshow
switchName: sw1
switchType: 2.4
switchState: Online
switchRole: Principal
switchDomain: 1
switchId: fffc01
switchWwn: 10:00:00:60:69:10:5e:09
switchBeacon: OFF
port 0: sw Online F-Port 50:06:0b:00:00:07:8a:de
port 1: sw Online F-Port 50:06:0b:00:00:14:73:8c
port 2: sw Online E-Port 10:00:00:60:69:10:6c:17 "sw3" (downstream)
port 3: sw Online F-Port 50:06:0b:00:00:0a:fd:a2
port 4: sw No_Light
port 5: sw No_Light
port 6: sw No_Light
port 7: sw No_Light
port 8: sw No_Light
port 9: sw No_Light
port 10: sw No_Light
port 11: sw No_Light
port 12: sw Online F-Port 50:06:0b:00:00:07:71:5e
port 13: sw Online E-Port 10:00:00:60:69:10:6c:17 "sw3"
port 14: sw Online F-Port 50:06:0b:00:00:14:65:2a
port 15: sw Online F-Port 50:06:0b:00:00:07:9c:84

sw1:admin> portshow 1
portFlags: 0x23805b PRESENT ACTIVE F_PORT G_PORT U_PORT LOGIN NOELP LED ACCEPT
portType: 3.1
portState: 1 Online
portPhys: 6 In_Sync
portScn: 6 F_Port
portRegs: 0x80020000
portData: 0x10f5d3e0
portId: 011100
portWwn: 20:01:00:60:69:10:5e:09

Distance: normal

Speed: 1Gbps

Interrupts: 3490 Link_failure: 2 Frjt: 0
Unknown: 48 Loss_of_sync: 11 Fbsy: 0
Lli: 86 Loss_of_sig: 6
Proc_rqrd: 3382 Protocol_err: 0
Timed_out: 0 Invalid_word: 0
Rx_flushed: 0 Invalid_crc: 0
Tx_unavail: 0 Delim_err: 0
Free_buffer: 0 Address_err: 3
Overrun: 0 Lr_in: 11
Suspended: 0 Lr_out: 5
Parity_err: 0 Ols_in: 5
Ols_out: 4

sw3:admin>switchshow
switchName: sw3
switchType: 2.4
switchState: Online
switchRole: Subordinate
switchDomain: 3
switchId: fffc03
switchWwn: 10:00:00:60:69:10:6c:17
switchBeacon: OFF
port 0: sw No_Light
port 1: sw Online L-Port 1 private, 5 phantom
port 2: sw Online E-Port 10:00:00:60:69:10:5e:09 "sw1" (upstream)
port 3: sw No_Light
port 4: sw No_Light
port 5: -- No_Module
port 6: -- No_Module
port 7: -- No_Module
port 8: -- No_Module
port 9: -- No_Module
port 10: -- No_Module
port 11: sw No_Light
port 12: sw No_Light
port 13: sw Online E-Port 10:00:00:60:69:10:5e:09 "sw1"
port 14: sw Online L-Port 1 private, 5 phantom
port 15: sw No_Light

sw3:admin> portshow 1
portFlags: 0x23806b PRESENT ACTIVE F_PORT L_PORT U_PORT LOGIN NOELP LED ACCEPT
portType: 3.1
portState: 1 Online
portPhys: 6 In_Sync
portScn: 6 F_Port
portRegs: 0x80020000
portData: 0x10f5d3a0
portId: 031100
portWwn: 20:01:00:60:69:10:6c:17

Distance: normal

Speed: 1Gbps

Interrupts: 86672 Link_failure: 0 Frjt: 0
Unknown: 11 Loss_of_sync: 2 Fbsy: 0
Lli: 6 Loss_of_sig: 0 Lip_in: 2
Proc_rqrd: 86657 Protocol_err: 0 Lip_out: 4
Timed_out: 0 Invalid_word: 0 Lip_rx: F7,F7
Rx_flushed: 0 Invalid_crc: 0
Tx_unavail: 0 Delim_err: 0
Free_buffer: 0 Address_err: 0
Overrun: 0 Lr_in: 0
Suspended: 0 Lr_out: 0
Parity_err: 0 Ols_in: 0
Ols_out: 0
--
Jeff Traigle
Jeff_Traigle
Honored Contributor

Re: Making ports N_Port instead of NL_Port

Think I found the problem... it's not the host or the switch causing the problem. The topology on the VA is what's set to Private Loop. Just noticed this in "armdsp -a" output. I haven't found the right command to change it yet though. I found "armmgr -y" to change the host port setting, but not an option to change the controller itself.
--
Jeff Traigle
m saravanan
Valued Contributor

Re: Making ports N_Port instead of NL_Port

Jeff,

Try the following command for both the controllers.

armmgr -t <2|4> -c <1|2>

wherein,
"t" is to set the topology,
2 - Public Loop
4 - Direct Fabric Attach

"c" is to select the controllers.

Hope it will help you.

Regds,
Saravanan
Jeff_Traigle
Honored Contributor

Re: Making ports N_Port instead of NL_Port

I'm thinking you have a different version of Command View or something. I'm using 1.09.01.%0184. The -t option is to set the Capacity Threshold warning percentage and -c is to reset the internal fibre channel link at an FRU location.
--
Jeff Traigle