HPE EVA Storage

QLA2340 via SAN - Slow drive access for certain applications?

 
IT_Ron
New Member

QLA2340 via SAN - Slow drive access for certain applications?

I have several ProLiant DL360 G4p Windows 2003 servers that access a Apple Xserve RAID (SAN) via HBA Fiber Channel card (QLA2340-CPQ (PCIX to FC single channel) for HP). These servers have been operational for years storing 80% of the company data on them with no problems what so ever.

Recently we docommissioned the last Netware 6.5 server that stored files for a few departments. The files were moved to a Windows 2003 server.

Users started noticing that the speed to access certain applications files was much longer after the move...

An example:
I have a financial program that accesses individual files (1-2MB in size) that are now stored on a Windows Server 2003 via SAN, previously these files were stored on a Netware 6.5 volume.

The problem is now when the financial program runs calculations on these files it takes the program 1.5 - 2 minutes to complete. Copy the same file back to the Netware server and run the identical process and it takes 5-10 seconds! Copy the file to a Ready NAS drive and it takes 5-10 seconds as well.

Saving larger Excel files also seems to take longer when stored on the SAN than on a Netware volume...

I have tried this on several of our Windows 2003 Servers connected to the SAN with the same HBA card, including test servers that no one uses and the time difference is the same!

All Network servers are on the same segment. The Network tests out fine. I ran a LAN Speed test from clients to the Servers and all can transfer 100MB fairly quickly with high network speeds. Faster than a local C share on a server or even the Netware volumes. I have tried multiple clients, including test PC's all with the same results. When the file is stored via SAN there is a huge delay in the process with this particular application...

Create a share on a Windows Server local C drive and no more delays...

Oddly enough we have programs that access much larger files through this system with no problems! It seems more application specific to the financial program and Excel.

I had contacted Qlogic with the problem, but they passed the buck onto HP as it is an OEM card!

Any help/suggestions on what I could look at to determine or fix this problem? The SAN seems to be operating fine with this exception!

Perhaps a driver update from HP (which I can't seem to find)?

Some details from the qlogic program they had me run:

HBA Model : QLA2340
HBA Description : QLA2340-CPQ (PCIX to FC single channel) for HP
HBA ID : 0-QLA2340
HBA Alias :
HBA Port : 1
Port Alias :
Node Name : 20-00-00-E0-8B-85-F9-8A
Port Name : 21-00-00-E0-8B-85-F9-8A
Port ID : 00-00-EF
Serial Number : D63257
Driver Version : SCSI Miniport 9.0.0.2 (w32 IP)
BIOS Version : 1.45
Driver Firmware Version : 3.03.06
Actual Connection Mode : Loop
Actual Data Rate : 2 Gbps
PortType (Topology) : NLPort
Target Count : 1
PCI Bus Number : 10
PCI Device Number : 1
HBA Status : Online
-----------------------------------------------
HBA Instance 0: QLA2340 Port 1 WWPN 21-00-00-E0-8B-85-F9-8A PortID 00-00-EF
--------------------------------------------------------------------------------
Connection Options : 2 - Loop Preferred, Otherwise Point-to-Point
Data Rate : Auto
Frame Size : 2048
Hard Loop ID : 0
Loop Reset Delay (seconds) : 5
Enable Host HBA BIOS : Disabled
Enable Hard Loop ID : Disabled
Enable FC Tape Support : Enabled
Operation Mode : 0 - Interrupt for every I/O completion
Interrupt Delay Timer (100ms) : 0
Execution Throttle : 16
Login Retry Count : 8
Enable LIP Reset : Disabled
Port Down Retry Count : 16
Enable LIP Full Login : Enabled
Link Down Timeout (seconds) : 8
Enable Target Reset : Enabled
LUNs Per Target : 128
-----------------------------------------------