HPE EVA Storage

RHEL 5.5 not seing presented volumes

 
BradV
Respected Contributor

RHEL 5.5 not seing presented volumes

When I present a new volume to RHEL attached through a fibre channel connection, I echo the scis id, LUN, and host bus adapter to /sys/class/scsi_host/host[01]/scan and multipath can then see the new volume.  I have another C7000 with BL460c G6s attached to an MSA2324sa through SAS switches.  I presented a new volume and tried to do a similar thing using /sys/class/sas_host... instead.  That didn't work.  So, I tried scsi_host - still no go.  I worked with Red Hat for over a week on this.  They insisted the sas_host methodology was correct.  However, there is nothing under /sys/class/sas_host, nor is there anything under /sys/class/scsi_host.  So, I just gave up and tried to reboot.  It not only did not find the new volume, it lost the current volume.  Multipath isn't seeing anything.

 

When I reboot the server, the P700m controller says it sees two logical drives.  However, if I hit F8 and attempt to view them.  It says there are no logical drives.  It also reports no physical devices.

 

Not sure where to go from here.  Any suggestions?

 

Regards,

 

Brad