HPE EVA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

RSM 5.2 unable to find Login Module

 

RSM 5.2 unable to find Login Module

Hi;
I have CVE9.3 and now I want to install RSM 5.2, I have Unlimited CVE an BC licenses. The server is a BL460G1 with W2K8 Std R2 64 bits SP1. When I start the RSM and write the login account (is in the HP Storage Admins group) the error is diplayed: Unable to find LoginModule class:org.jboss.client.security.clientloginmodule...
I tried the disable UAC and to replace the SAL* files from SMI-S, with no solution.
I append some pictures of the errors, and the message when I ran the RSM as Administrator.
Any idea?, thanks;
3 REPLIES 3

Re: RSM 5.2 unable to find Login Module

As you have mentioned that you have already tried to disable UAC (User Access Control) and I hope you have moved the files SALCommon.jar, SALEva.jar and SALhprsm.jar. So please try the following,

While invoking RSM shortcut C:\Program Files\Hewlett-Packard\RSM\JBoss\server\default\deploy\rsm-client.war\gui.cmd from desktop, it opens a command window with non-administrative access which prevents the creation of comp.txt and jars.txt files in directory C:\Program Files\Hewlett-Packard\RSM\JBoss\server\default\deploy\rsm-client.war, which causes the login failure.

If UAC is enabled, cmd will open the command windows in non-administrative mode unless otherwise specified.

Disable User Account Control in Windows and run the RSM.

Next workarounds can be applied even if UAC is enabled.

Execute the RSM from command line as follows:

Open a command window by selecting Run as administrator.

In the command line, go to C:\Program Files\Hewlett-Packard\RSM\JBoss\server\default\deploy\rsm-client.war.

Use cd C:\Program Files\Hewlett-Packard\RSM\JBoss\server\default\deploy\rsm-client.war.

Then, execute the command gui.cmd.

Edit RSM GUI.CMD startup script as follows:

Back up the file C:\Program Files\Hewlett-Packard\RSM\JBoss\server\default\deploy\rsm-client.war\gui.cmd.

Edit the file and add the following as first line.

Perform cd C:\Program Files\Hewlett-Packard\RSM\JBoss\server\default\deploy\rsm-client.war .

Replace the original file with the edited one.

Right-click and execute the shortcut on desktop by selecting run as administrator.

I work for HPE
Accept or Kudo
Occasional Contributor

Re: RSM 5.2 unable to find Login Module

SUBHAJIT KHANBARMAN_1, thanks for reply. It works for me.

Occasional Visitor

Re: RSM 5.2 unable to find Login Module

Thanks very much. Worked as a champ even in version 5.5. Seems that HP carry bugs from one version to the other one perfectly... :-)