HPE EVA Storage

Strange san-switch port status

 
SOLVED
Go to solution
Prokopets
Respected Contributor

Strange san-switch port status

Hi!
I have a strange issue with brocade san switch. First, i lost the connection with a storage. switchshow looked like this (port #4):
====
IBM_2005_16B:admin> switchshow
switchName: IBM_2005_16B
switchType: 34.0
switchState: Online
switchMode: Native
switchRole: Subordinate
switchDomain: 5
switchId: fffc05
switchWwn: 10:00:00:05:1e:02:d7:5f
zoning: ON (Production)
switchBeacon: OFF

Area Port Media Speed State Proto
=====================================
0 0 id N4 Online E-Port 10:00:00:05:1e:03:eb:13 "Core_A" (upstream)
1 1 id N4 No_Light
2 2 id N4 Online F-Port 10:00:00:00:c9:5d:2d:bd
3 3 id N4 No_Light
4 4 id N2 Online Loopback->Port 4
5 5 id N2 Online F-Port 21:00:00:e0:8b:86:0f:37
6 6 id N4 Online F-Port 20:25:00:a0:b8:38:9a:62
7 7 id N4 No_Light
8 8 id N4 No_Light Disabled
9 9 id N4 No_Light Disabled
10 10 id N4 No_Light Disabled
11 11 id N4 No_Light Disabled
12 12 -- N4 No_Module Disabled
13 13 -- N4 No_Module Disabled
14 14 -- N4 No_Module Disabled
15 15 -- N4 No_Module Disabled
====

I made portdisable\portenable and now switchshow output looks like this:

====
IBM_2005_16B:admin> switchshow
switchName: IBM_2005_16B
switchType: 34.0
switchState: Online
switchMode: Native
switchRole: Subordinate
switchDomain: 5
switchId: fffc05
switchWwn: 10:00:00:05:1e:02:d7:5f
zoning: ON (Production)
switchBeacon: OFF

Area Port Media Speed State Proto
=====================================
0 0 id N4 Online E-Port 10:00:00:05:1e:03:eb:13 "Core_A" (upstream)
1 1 id N4 No_Light
2 2 id N4 Online F-Port 10:00:00:00:c9:5d:2d:bd
3 3 id N4 No_Light
4 4 id N2 Online L-Port 1 public
5 5 id N2 Online F-Port 21:00:00:e0:8b:86:0f:37
6 6 id N4 Online F-Port 20:25:00:a0:b8:38:9a:62
7 7 id N4 No_Light
8 8 id N4 No_Light Disabled
9 9 id N4 No_Light Disabled
10 10 id N4 No_Light Disabled
11 11 id N4 No_Light Disabled
12 12 -- N4 No_Module Disabled
13 13 -- N4 No_Module Disabled
14 14 -- N4 No_Module Disabled
15 15 -- N4 No_Module Disabled
====

Now server can see storage but i'm not sure about status of port... What does they mean under this two statuses: "Loopback->Port 4" and "1 public" ?

Regards,
Philipp.
4 REPLIES 4
Uwe Zessin
Honored Contributor
Solution

Re: Strange san-switch port status

L_Port means that the switch is talking to a device that uses Fibre Channel Arbitrated Loop (FC_AL) protocol for communication. 'Public' means the device uses 24-bit fabric compatible addresses not simple 8-port AL_PAs.

Loopback means the switch port talks to itself. Did somebody connect a device through an FC_AL hub to the switch port?
.
Prokopets
Respected Contributor

Re: Strange san-switch port status

Uwe, thanks for reply!
As for FC_AL hub - i'm sure that no one did this because we just have no such devices. Can it be a storage problem\malfunction (there's a Sun storage connected in this port)?
Uwe Zessin
Honored Contributor

Re: Strange san-switch port status

Ah, maybe the storage device has rebooted...
If its running FC_AL, the port could go into bypass mode when it is not operational and that can explain why the switch saw a loopback.
.
Prokopets
Respected Contributor

Re: Strange san-switch port status

Uwe, i think you're right, because we had a problems with cooling, the storage became crazy and shut down after overheating. Thanks for help!

Philipp.