HPE EVA Storage

Unable to delete logical drive on MSA1500

 
toomas_aas
Frequent Advisor

Unable to delete logical drive on MSA1500

Hello!

One logical drive on our MSA1500 (firmware 5.20) developed a problem, reporting in hpacucli 'show config detail' that "Parity Initialization Failed" (note this is not a new drive, it was previously OK). In ADU, the status of this logical drive was shown as "consistency check failed". There were no noticeable problems for the host having access to this logical drive - it was still fully accessible and no data corruption was noticed.

However, the recommendation from local HP support personnel was to delete and re-create the logical drive. Since this is the last logical drive on the array, it should be possible. I migrated the data off the logical drive, but now I find I can't delete the drive. When in hpacucli I issue the command
ctrl ch="mymsa" ld 8 delete
it prompts for confirmation, after receiving 'y' it sits there for a couple of minutes and returns with no further messages, however the logical drive is not deleted.

I also tried to delete the drive using ACU-XE, but the results are similar - after hitting "save" it sits there for a few minutes, then returns but the drive is still there. Then I tried to start "migrate stripe size" operation on the logical drive, hoping that this would rebuild the parity info and bring the drive back to health, but it seems that this operation also doesn't start.

The only idea I have left is to fully power cycle all the attached servers, MSA1500 and disk shelves. But maybe someone can suggest a better way?
3 REPLIES 3
toomas_aas
Frequent Advisor

Re: Unable to delete logical drive on MSA1500

I have to add one more thing. When I attempt to delete the LUN or start stripe size migration, the process doesn't just "sit there". It actually causes IO errors for *all* hosts connected to the MSA1500. Eek!
patrick haynes
Frequent Advisor

Re: Unable to delete logical drive on MSA1500

would suggest to disconnect all hosts but one, then boot that one using msa support cd and delete array, imho
toomas_aas
Frequent Advisor

Re: Unable to delete logical drive on MSA1500

Turns out the root cause was a disk silently going bad.

While working in the server room, I noticed that the access light (green arrow) on one particular disk in a 12-disk array was on almost constatntly, while on other disks it flashed only infrequently. Status of this disk in ACU showed no problems.

By next day the disk had gone into predictive failure state and was replaced by HP. After the disk was replaced and array had rebuilt, the problematic logical drive showed that it's consistency check was OK again, even though this logical drive was not on the array with failing disk.

I came in next morning only to discover that the newly replaced disk was also in predictive failure state. Additionally, one other drive had gone into predictive failure state, and this one was indeed part of the array which hosts the problematic logical drive.

I upgraded the firmware of MSA1500 to 5.30 (was 5.20), and also upgraded the firmware of disks, using the latest HP Firmware Update CD (8.70). After that, HP decided to replace the disks once more, and fortunately the disks seem fine now.

I just deleted and re-created the problem logical drive, and had no trouble doing so. Even though it's status looked OK now, I decided to take this step because I had already migrated the data off the drive and had nothing to lose anyway.