HPE EVA Storage

Unable to setup load balancing MPIO on iSCSI


Unable to setup load balancing MPIO on iSCSI



We have a P2000 G3 SAN that is connected with two iSCSI connections to a Proliant G380 G7. There is no switch between them.  Both connections work, but not together.


The one I initialize first will be the only one that will be used, even when Least Blocks or Lease Queue Depth is selected. One path is active/optimized, the other is active/unoptimized and is therefore never used. I can't change the path to active/optimized:

  • I've tried through the Device Manager > HP P2000G3 > MPIO. It gives an error message but with with no exception, just the explanation of wht the MPIO policy does with a red cross image next to it.
  • Via the MPCLAIM utility (mpclaim -l -d 4 4 0000000077010000 0 0 0) it tells me that it 'Failed to successfully execute DsmSetLoadBalancePolicyALUA. The parameter is incorrect'.
  • iSCSI Initiator. The hp:storage.p2000g3 is connected with two sessions. Selecting 'Devices > MPIO' tells me the Load balancy policy and that is has two paths, both connected and active. Changing it gives a 'parameter incorrect'.

 After keep failing in setting it the MPIO to use more than the active path, i've updated the server's NIC as a last resort. The iSCSI version went from 4.xx to 7.xx, but with no change when trying to set all paths to active. I´m out of idea´s. I also do n't have the possibility to select Round Robin and I also don't know why.

I think i've read almost every document regarding to MPIO and HP's own manuals about the P2000, iSCSI and MPIO. It should almost work out of the box, but I don't know why.



1 volume on a vdisk has a explicit mapping on the iSCSI ports A4 and B4 (seperate controllers)

Host interfaces on A4 is ( and B4 has

CHAP is disabled, link speed Auto, IP version 4, Jumbo frames enabled an iSNS disabled.


G360 G7:

  • Enabled iSCSI on the NIC's through the HP Network. I've also set the IP adress in the HP utility. If I open it through the normal windows network to show it's details, the IP adress is different than the iSCSI one.
  • iSCSI uses and
  • The two iSCSI NIC's are not in a VLAN and aren't teamed
New Member

Re: Unable to setup load balancing MPIO on iSCSI

I have the same issue on HP DL360p Gen8 with P2000 G3 MSA FC/iSCSI. Tried it on Windows Server 2008 R2 and Windows Server 2012. What can I check to make it work?


Occasional Visitor

Re: Unable to setup load balancing MPIO on iSCSI

Did u try this "mpclaim -n -i -a" & "reboot" , maybe it's work!! (PS:My lab HP P2000 G3 with Windows Server 2012 Standard)