HPE EVA Storage

Update EVAs4000 desde XCS 6100 a la 6220

 
SOLVED
Go to solution
JuanCG
Super Advisor

Update EVAs4000 desde XCS 6100 a la 6220

Hi all, I have two EVA4000 then updated (EVA Backp and Production) with the following configuration:

- Replicate AC and BC.
- Version 6.0.2.37 Command View
- Version 6100 XCS
- They both FATA and FC disks
- I have to upgrade to version 6220 of XCS and 9.2 of Command View
- San switches have the 5.0.5 version 5.2.1b and FOS (Brocade).
- There are 6 models switchest Brocade 200E and 4024

The procedure I follow is:

1. Stop access to the servers vDisks
2. CA Stop replication
3. Command View upgrade to 9.2
4. XCS update the 6220 directly to the EVA4000 Backup
5. Upgrade the disks in the backup EVA
6. Upgrade EVA 6220 XCS to directly.
7. Upgrade the disk from the EVA Production.
8. CA replication initiation.
9. Start the server access to vDisks
10. The firmware switches the left as they are.


THIS METHOD IS CORRECT? DO I HAVE TO DO ANYTHING ELSE THAT I FORGET?

VIEW Comm LICENSES ARE NOT VALID FOR 6 THE VIEW COMMAND 9.2, HOW CAN I GET THE LICENSE VALID?

IS THERE ANY DOCUMENT ME EXPLAIN EXACTLY WHAT ALL I HAVE TO CHECK?

THANK YOU!! :)
6 REPLIES 6
Jan Soska
Honored Contributor

Re: Update EVAs4000 desde XCS 6100 a la 6220

Hello,

You plan quit big update... :)
So first: you need to have active CV subscription to get licence codes for CV 7+, do you have one? If yes, my sugestion is:

1) update SAN switches firmware to latest 6.3.x - will require lot of jumps between version!
2) update EVA firmware to 6220
3) update CV to latest CV9.3
4) update drives firmware with Eva disk firmware bundle

we do not use CA, but I am afraid there are limit which firmwares are compatible, so probably you'll need to temporary disable CA and upgrade both evas in short time.

generally, you do not need to disconnect servers from vdisk, all this could by done online, but find time windows with low IO request and make sure you have multipath active and really working all all servers behind evas.

Jan
JuanCG
Super Advisor

Re: Update EVAs4000 desde XCS 6100 a la 6220

Hi Jan, thank you very much for answering. I think that for reasons of time I'll leave the FC switches to the version you are.

Is there any incompatibility for that?

The order to follow is to first install the VC version 9.2, as it enters the array and is best to upgrade the XCS to a later version of CV.

JAN thank you very much!
Jan Soska
Honored Contributor
Solution

Re: Update EVAs4000 desde XCS 6100 a la 6220

Hello,

if you keep FC switches under old firmware, you:
- run out of suport matrix
- risk some issues, depends on configuration, but until we did not upgrade Fabric OS to 6.2x, we faced issues with vmware (disapeared after upgrading!)

I forgot to mention - upgrade FC HBA firmware/drives after such upgrade - highly recommended.

Remember latest CV is 9.3 - but probably you'll need to find latest CV compatible with eva firmware 6100, check HP manuals/docs for CV at http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?contentType=SupportManual〈=en&cc=us&docIndexId=64179&taskId=101&prodTypeId=12169&prodSeriesId=471497

Jan
Jan Soska
Honored Contributor

Re: Update EVAs4000 desde XCS 6100 a la 6220

JuanCG
Super Advisor

Re: Update EVAs4000 desde XCS 6100 a la 6220

Thank you very much again, Jan, which tells me of fiber switches support issue is not non-compatibility issue?

This is important because this upgrade will take place later.

Thank you very much!
Jan Soska
Honored Contributor

Re: Update EVAs4000 desde XCS 6100 a la 6220

Hard to say... each release of fabric OS brings new features AND fixes. We noticed vmware issue.
anyway, upgrading storage core infrastructure is highly recomenend. In case you face any issue, HP support will require have all firmwares inside support matrix...


Jan