HPE EVA Storage

Updating HP StorageWorks Fibre Channel Adapter Kit for the x86 QLogic Storport Driver

 
JasonWoerner
Frequent Advisor

Updating HP StorageWorks Fibre Channel Adapter Kit for the x86 QLogic Storport Driver

The Version Control Agent states I'm on 1.3.0.1. I can successfully run updated installations but the version remains the same. I have also obtained the drivers from HP's site directly and succeeded in updating the Storport driver itself, but the software referenced in VCA remains at the old version. Any suggestions?
8 REPLIES 8
Brett Pierron
New Member

Re: Updating HP StorageWorks Fibre Channel Adapter Kit for the x86 QLogic Storport Driver

Anyone have an answer for this?

I am having a very similar issue and have been for a while. I am currently at version 1.4.0.1 and have remained there for the last two Support Packs. As 8.0 came out, I would install the update to version 1.5.0.0. The install performs correctly and requires a reboot. After the reboot, the version still remains at the old version of 1.4.0.1. I thought it could just be an issue with 1.5.0.0, so I decided to wait until the next PSP came out. Now that 8.10A is out, I am attempting to update to 1.6.0.0 and have the same results. It installs correctly, requires a reboot, reboots, and the version is still 1.4.0.1. I prefer to keep that all Green SW Status in SIM and VCA, and this has been keeping me from that for a while.

Any suggestions?
Keith Peppiatt
New Member

Re: Updating HP StorageWorks Fibre Channel Adapter Kit for the x86 QLogic Storport Driver

I have a similar issue with the Emulex versions too. 1.5.0.0 will not update to 1.9.0.0 in latest pack or 1.6.0.2 its predecessor. I have tried manual update too but VCA still reports 1.5.0.0. when i run at server manually it says there it failed to install check setup.log file... that just states exactly what was shown on screen. No sign of errors in event logs either... well puzzled.
Brett Pierron
New Member

Re: Updating HP StorageWorks Fibre Channel Adapter Kit for the x86 QLogic Storport Driver

Ok all,

I figured out a way to fix this, based upon a previous issue I had where the QLogic device was not showing at all in VCA.

Here are the steps to take.

OPTION 1
1.) Locate/download cpxxxxxx.exe. You can find it in the VCA Repository Manager. Just find the version you want to upgrade to, and download the file.
2.) Instead of running the install, extract it's contents into a directory of your choosing.
3.) Copy QlStorPortVer.exe from that extraction location to C:/StorageWorks/Version. If older version is currently there overwrite it. If QlScsiPortVer.exe is in C:/StorageWorks/Version currently delete it.
4.) Once this is done the problem will be resolved. If you check VCA immediately after the change the version does not update immediately. It takes about five minutes and a refresh of SMH in order for the version to update in VCA. Otherwise, a reboot of the machine will give you an immediate result.

Hope this helps everyone!
Rob Buxton
Honored Contributor

Re: Updating HP StorageWorks Fibre Channel Adapter Kit for the x86 QLogic Storport Driver

Just a note you may get more of a response on issues with the VCA in the HPSIM Forum.
JasonWoerner
Frequent Advisor

Re: Updating HP StorageWorks Fibre Channel Adapter Kit for the x86 QLogic Storport Driver

Brett, your steps did resolve the issue of an old version number appearing in the Version Control listing. But I'm curious whether this is a real fix or just a way of fooling the VC Agent. Could I place any version in the folder you suggest, no matter which is actually installed on the machine, and see it reflected in the VC listing? I suspect this may be the case. However, I think the root problem here is that the installation program for this component doesn't update the file under the StorageWorks folder. So I'm satisfied to do it manually until HP fixes.

Thanks!
Júlio Ramos
New Member

Re: Updating HP StorageWorks Fibre Channel Adapter Kit for the x86 QLogic Storport Driver

Hello all,
Since at this moment I'm seeking for more info about a Customer Advisory from HP, telling that "HP Fibre Channel Host Bus Adapters - OS May Loose Contact To Shared Storage Following A ProLiant Support Pack Upgrade Or Fibre HBA Driver Upgrade" (http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c01141465)
and in this case, occurs that SmartStart 8.2 DOES NOT deploy any driver for your HBA, for example, my BL680cG5 was installed using SmartStart, but have not installed driver for QMH2462 Mezzanie HBA, so I have to go online get the driver then deploy. (this is described on Release Notes for this version of SmartStart).

Best Regards,
ThomVis
Advisor

Re: Updating HP StorageWorks Fibre Channel Adapter Kit for the x86 QLogic Storport Driver

Just my 2 cents.
I've tried Brett Pierron's solution, and indeed, VCA is very happy. I was not after I rebooted the server, my SAN storage wasn't visible from the server anymore.
And all that for just ones and zeros
Martin2000
Occasional Visitor

Re: Updating HP StorageWorks Fibre Channel Adapter Kit for the x86 QLogic Storport Driver

This worked for me:

 


@Brett Pierron wrote:
Ok all,

I figured out a way to fix this, based upon a previous issue I had where the QLogic device was not showing at all in VCA.

Here are the steps to take.

OPTION 1
1.) Locate/download cpxxxxxx.exe. You can find it in the VCA Repository Manager. Just find the version you want to upgrade to, and download the file.
2.) Instead of running the install, extract it's contents into a directory of your choosing.
3.) Copy QlStorPortVer.exe from that extraction location to C:/StorageWorks/Version. If older version is currently there overwrite it. If QlScsiPortVer.exe is in C:/StorageWorks/Version currently delete it.
4.) Once this is done the problem will be resolved. If you check VCA immediately after the change the version does not update immediately. It takes about five minutes and a refresh of SMH in order for the version to update in VCA. Otherwise, a reboot of the machine will give you an immediate result.

Hope this helps everyone!