HPE EVA Storage

Upgrade to EVA 8100 and Solaris 9

 
Vladana
Occasional Contributor

Upgrade to EVA 8100 and Solaris 9

Hello,

I have three SUN sparc machines (Sun Fire V240, E6900 and V880) that run Solaris 9. All three of them had 2 HBA FCA2257P, QLA2300 driver, that were initially used to connect to EVA 5000 with Secure Path 3.0D-1.

Recently we have upgraded EVA from 5000 to 8100.

At first, I was told that those HBAs are supported with mpxio, qla driver v5.03 and new EVA (doc. EVA4000/4100 EVA6000/6100 EVA8000/8100 Solaris 9 (SPARC) compatibility matrix), but that didn't work, so I removed qla driver (# pkgrm QLA2300), and rebooted servers, for SUN native qlc driver to take over. In couple of documents I have found that this combination is supported.

After reboot, I configured devices with cfgadm, everything works fine now, qlc drivers attached just fine, and mpxio took over Secure Path. I have not removed Secure Path, just disabled it from booting (removed 5 rc scripts):
/etc/rc0.d/K36spinit
/etc/rc1.d/K36spinit
/etc/rc2.d/S89spinit
/etc/rcS.d/K36spinit
/etc/rcS.d/S89spinit

However, there is certain error during reboot, which repeats more that 150 times, and is related to previous HBA QLogic driver:
WARNING: add_spec: No major number for qla2300

and later, when system is up and running, it can be seen in logs, but not as frequently as during reboot.

What is the reason for this warning, can it cause system to hang, and how can it be solved?

Could it be that following rc scripts caused it?
/etc/rcS.d/S10hsx
/etc/rcS.d/S44spdrv
As I can see, they load drivers for secure path. If I remove them from boot scripts, could I cause something else to fail?
I have read the following manual "HP StorageWorks Secure Path 3.0D Service Pack 1 for Sun Solaris" but there is nothing there about these scripts or those rc spinit scripts.

Thank you very much for your help,
Best regards,
Vladana