HPE EVA Storage

Win2003 Doesn't See Luns, HP EVA 3000 SAN

 
ckuriyar
New Member

Win2003 Doesn't See Luns, HP EVA 3000 SAN

Hi,

I have a HP SAN connected with 1 windows server. All connecting to EVA 3000, all use QLE 2460 HBA, using HP storageworks 4/8 SAN switch.

I have installed the latest drivers and it has driver version STOR Miniport 9.1.8.25, boot version 5.01.03

Also I have installed SANsurfer application, I can see the topology, HP command view EVA server, SAN switch and storage array.

I configured the zoning in the switch and created with 2 EVA servers & windows server part of the zone.

The windows 2003 server cannot see its luns. I've double/triple checked the configuration - yet neither hba in that server sees the luns.
But when I look into the SANsurfer application, I can't see the LUN's and it shows 0

When I try to configure the LUN, it shows the error " Failover driver not installed and so preferred & alternate paths to this device can not be configured"

Any suggestions on next steps to identify the cause?

Chandru
7 REPLIES 7
Stephen Kebbell
Honored Contributor

Re: Win2003 Doesn't See Luns, HP EVA 3000 SAN

Hi,

have you defined a Host in Command View EVA with the WWNs of the 2 HBAs?
Did you install the EVA MPIO software on the Windows server?
What can you see in Device Manager (under Disk Drives and SCSI/RAID Controllers)?
Can you provide your zoning configuration? (telnet to a SAN switch and provide the output of cfgshow)

Regards,
Stephen
Michael A. McKenney
Respected Contributor

Re: Win2003 Doesn't See Luns, HP EVA 3000 SAN

On my MSA 2012fc, I have to go into the SAN and assign the host (HBA) to the LUN for r/w. Otherwise, the server can't see the LUNs.
ckuriyar
New Member

Re: Win2003 Doesn't See Luns, HP EVA 3000 SAN

can you please send me the steps how we can do this. Iam new to this and first time we are installing this SAN hardware.
Michael A. McKenney
Respected Contributor

Re: Win2003 Doesn't See Luns, HP EVA 3000 SAN

On my MSA2012fc, I log into the SAN maangement utility.

Manage
Volume Management
Volume mapping
1.) manage host list: Name the HBA to your server. I have two HBAs per server so one is Server1_A and Server1_B
2.) Map Hosts to Volume
Click on each Vdisk, then each LUN/Volume and assign the HBA to that LUN for R/W. If you have mulitple LUNs per server, do each one. Assign both HBAs if two on on each server.

This gives r/w to the HBA in the server to see the LUN and boot.
Sivaramakrishna_1
Honored Contributor

Re: Win2003 Doesn't See Luns, HP EVA 3000 SAN

Hi,

I think Michael shared the steps of MSA storage where as you mentioned the storage EVA 3000.

1. Note down the Port WWN of HBA (from either SAN Switch or SAN surfer you installed in that server).
2. Open the Command View EVA and click on Hosts -> Add Host
Give the host name and selct the Operating system "Microsoft Windows".
3. The select the Vdisk (if it is created already) and select "Presentation" and click select on the host you created and click "present vdisk"

then do a rescan from Windows Host (some time reboot required if rescan not works) and you will find the vdisk allocated to server.

Make sure that correct version of MPIO installed on the machine.
ckuriyar
New Member

Re: Win2003 Doesn't See Luns, HP EVA 3000 SAN

Thanks for your support.

We did the same but still can't see the LUN's in windows server.

Does this really the MPIO drivers are not installed properly? can anyone give me the path to download the right drivers?

I have used Dell Optiplex 745 with windows server 2003 SP2.

When I try to configure the LUN, it shows the error " Failover driver not installed and so preferred & alternate paths to this device can not be configured"

Sivaramakrishna_1
Honored Contributor

Re: Win2003 Doesn't See Luns, HP EVA 3000 SAN

Hi,

Below is the location.

HP MPIO Full Featured DSM (Device Specific Module) for EVA3000/5000 VCS 4.xxx Disk Arrays
http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=18964&prodSeriesId=421492&prodNameId=421494&swEnvOID=1005&swLang=13&mode=2&taskId=135&swItem=co-68693-1

HP MPIO Basic DSM (Device Specific Module) for Windows for EVA3000/5000 VCS 3.xxx Disk Arrays:
http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=18964&prodSeriesId=421492&prodNameId=421494&swEnvOID=1005&swLang=13&mode=2&taskId=135&swItem=co-54265-1


Please dont forget to assign points if it helps..

Thanks,
Siva