autopath config

 
klb
Valued Contributor

autopath config


HPUX 11.11 EoE
EVA 6400
autopath ( securepath )
HPswsp A.3.0F.03F.00F

I can't seem to get the autopath to recognize that I have an array. The OS can see a test LUN via ioscan and I/O to/from the LUN is working. However, autopath just returns with messages indicating no SecurePath device found.

What must I do to make autopath/securepath software recognize the EVA and its LUNs?

after ioscan and insf -e:
# autopath discover
AUTOPATH : discovery of new paths / LUNs will be effective only if ioscan and insf -e are executed prior to autopath discover
AUTOPATH : discover in progress ...
AUTOPATH : discover successful

# autopath display

AUTOPATH : no SecurePath device found

# autopath add /dev/dsk/c2t15d0

AUTOPATH : not a valid SecurePath device

# autopath add -l 6005-08b4-000e-36ff-0000-3000-007e-0000

AUTOPATH : not a valid SecurePath device

Thanks,

-klb
10 REPLIES 10
klb
Valued Contributor

Re: autopath config


I'm getting this in syslog:

vmunix: GetWWN: Devt is bc02f000
vmunix: AUTOPATH: Device bc02f000 belongs to an unsupported array type
vmunix: AUTOPATH: Unable to get lun WWN for the device-bc02f000 .
This lun will not be included back into autopath control

According to one itrc doc, updating the HBA drivers takes care of it. Not in my case unfortunately as after updating driver to 11.11.16, nothing changed.

I've disabled all zoning too just for kicks with no joy.

Any ideas?

-klb
Sameer_Nirmal
Honored Contributor

Re: autopath config

What's the model of the installed FC HBA and connected to what array?
klb
Valued Contributor

Re: autopath config

The adapters are AB379 4Gb Dual port. The array is EVA6400.

Thanks,

-klb
Sameer_Nirmal
Honored Contributor

Re: autopath config

Does the system have SCSI ULM Services bundle installed? If not, then you would need to install it from HP-UX application CD.
klb
Valued Contributor

Re: autopath config


Yes ULM-SERVICE is installed ( can't install SP without it ).
klb
Valued Contributor

Re: autopath config


OK everybody, my back is up against the wall on this one. The securepath software doen't seem to be working as it should. However, if my array really isn't supported, it's working perfectly. So...

Can someone confirm that my setup is supported under SecurePath for Active/Active arrays ( autopath )? Even the docs are a bit fuzzy here.

Array: EVA6400
controllers: HSV400
switch: brocade??
HBA: HP AB379-60001
Server: rp7420
OS: 11.11

The message about having an unsupported array type appears in syslog whenever I attempt to add a LUN based on its WWN:

vmunix: GetWWN: Devt is 1f090100
vmunix: AUTOPATH: Device 1f090100 belongs
to an unsupported array type
vmunix: AUTOPATH: Unable to get lun WWN
for the device-1f090100. This lun will
not be included back into autopath control

The os has been patched as specified in:
o release notes for SecurePath
o install guide for SecurePath
o release notes for HBA driver FibrChanl-01
o release notes for HBA driver FibrChanl-00

Firmware at the HBA and PDC have been updated to latest level.

Firmware at the EVA is at 09501200 ( can't get this updated just yet ).

I have uninstalled and reinstalled SecurePath as well.

Any ideas?

thanks,

-klb
Uwe Zessin
Honored Contributor

Re: autopath config

> HPswsp A.3.0F.03F.00F

You need service pack 4, SP3 is too old and does not recognize the EVA6400.
.
klb
Valued Contributor

Re: autopath config


RE: SP4.

Installed SP4. Now the software works as advertised.

Thanks you Sir,

-klb