HPE EVA Storage

brocade san switches trunk configuring snmp

 
A.W. Benjamin
Advisor

brocade san switches trunk configuring snmp

We have connected two SAN switches with two ISL's forming a trunk. One port is the trunk master. The SAN switch is configured to send snmp traps. When we disconnect or disable the non-master port then we receive an snmp message within HPSIM. When we disconnect the master port than we receive no snmp trap ? How is this possible ?
2 REPLIES 2
Umit Ozdemir
New Member

Re: brocade san switches trunk configuring snmp

I guess you have to configure snmp mib capability,

use the follow command
snmpconfig --set mibcapability
then choose yes for each item you want to receive traps,


Sivakumar MJ._1
Respected Contributor

Re: brocade san switches trunk configuring snmp


Configure Brocade SNMP--->
Log in to the CLI interface using Telnet, or use Brocade Switch Explorer.

Use the CLI command agtcfgset or the more recent snmpconfig to enter the SNMP configuration mode.

Enter the IP address of the OSEM host into one of the trap destination settings.

Set the mibCapability to enable at least SW-TRAP, FA-TRAP and/or HA-TRAP MIB traps.

If the access control list has any entries, ensure that the domain of the OSEM host is also included in this list. The above configuration can also be done via the switches embedded web interface. Refer to the switch configuration guide for details on how to configure trap severity levels and MIB capabilities if required.

Enter the details into the Managed Systems page and select the system type as B series FC switch for Brocade branded switches, or FC switch for HP StorageWorks FC switches.

--------------------------------------------



Can you provide me the output of
#snmpConfig --show snmpv1

Try....

switch:admin> snmpconfig --show mibCapability
FE-MIB:YES
SW-MIB: YES
FA-MIB: YES
FICON-MIB: YES
HA-MIB: YES
FCIP-MIB: YES
ISCSI-MIB: YES
SW-TRAP: YES
swFCPortScn: YES
swEventTrap: YES
swFabricWatchTrap: YES
swTrackChangesTrap: YES
FA-TRAP: YES
connUnitStatusChange: YES
connUnitEventTrap: YES
connUnitSensorStatusChange: YES
connUnitPortStatusChange: YES
SW-EXTTRAP: YES
FICON-TRAP: YES
linkRNIDDeviceRegistration: YES
linkRNIDDeviceDeRegistration: YES
linkLIRRListenerAdded: YES
linkLIRRListenerRemoved: YES
linkRLIRFailureIncident: YES
HA-TRAP: YES
fruStatusChanged: YES
cpStatusChanged: YES
fruHistoryTrap: YES
FCIP-TRAP: YES
linkUpTrap: YES
linkDownTrap: YES

-------------and set-------------
switch:admin> snmpconfig --set seclevel
Select SNMP Security Level
(0 = No security, 1 = Authentication only,
2 = Authentication and Privacy, 3 = No Access): (0..3) [0] 1
Select SNMP SET Security Level
(0 = No security, 1 = Authentication only,