HPE EVA Storage

installation of hp_qla2x00-2009-03-17.tar.gz on RHEL 5.4 fails

 
Herbert Herzog
Occasional Advisor

installation of hp_qla2x00-2009-03-17.tar.gz on RHEL 5.4 fails

Hi,

I upgraded to RHEL 5.4 and tried to upgrade the Linux Driver Kit for HP Qlogic HBAs and mezzanine HBAs drivers from 8.01.07.25.02 (11 Nov 2008) hp_qla2x00-2007-10-05b.tar.gz to the newer 8.02.23 (24 Apr 2009) hp_qla2x00-2009-03-17.tar.gz. But the installations fails with:

This RPM is not supported on RHEL 5.3 or greater

The ./INSTALL script reports the following messages:

[root@dvxoel201 hp_qla2x00-2009-03-17]# ./INSTALL
Upgrading hp_qla2x00src RPM...

Preparing... ########################################### [100%]

This RPM is not supported on RHEL 5.3 or greater

error: %pre(hp_qla2x00src-8.02.23-1.noarch) scriptlet failed, exit status 1
error: install: %pre scriptlet failed (2), skipping hp_qla2x00src-8.02.23-1

Installing fibreutils...

Preparing... ########################################### [100%]
package fibreutils-3.0-3.i386 (which is newer than fibreutils-2.5-4.i386) is already installed
[root@dvxoel201 hp_qla2x00-2009-03-17]# rpm -e fibreutils
[root@dvxoel201 hp_qla2x00-2009-03-17]# ./INSTALL
Upgrading hp_qla2x00src RPM...

Preparing... ########################################### [100%]

This RPM is not supported on RHEL 5.3 or greater

error: %pre(hp_qla2x00src-8.02.23-1.noarch) scriptlet failed, exit status 1
error: install: %pre scriptlet failed (2), skipping hp_qla2x00src-8.02.23-1

Installing fibreutils...

Preparing... ########################################### [100%]

This RPM is not supported on RHEL 5.3 or greater

error: %pre(fibreutils-2.5-4.i386) scriptlet failed, exit status 1
error: install: %pre scriptlet failed (2), skipping fibreutils-2.5-4
[root@dvxoel201 hp_qla2x00-2009-03-17]#

In the release notes of this version I found that RHEL 5.3 and 5.4 are supported. Could anyone help me?

Thanks,
Herbert


4 REPLIES 4
Michal Kapalka (mikap)
Honored Contributor

Re: installation of hp_qla2x00-2009-03-17.tar.gz on RHEL 5.4 fails

hi,

the error of the script alredy gave you an answer :

This RPM is not supported on RHEL 5.3 or greater

mikap
Herbert Herzog
Occasional Advisor

Re: installation of hp_qla2x00-2009-03-17.tar.gz on RHEL 5.4 fails

Hi,
I know that the script does not support that, but in the release notes of the webside the RHEL 5.4 is supported.

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=12169&prodSeriesId=315739&prodNameId=315741&swEnvOID=4006&swLang=8&mode=2&taskId=135&swItem=co-74973-1

And it is mysterious that a newer version of the driver does not support the newer OS.

The older driver version 8.02.11-1 (2 Jul 2008) supports RHEL 5.4. I think there could be some error in the script.

Best regards,
Herbert
Michal Kapalka (mikap)
Honored Contributor
Michael Leu
Honored Contributor

Re: installation of hp_qla2x00-2009-03-17.tar.gz on RHEL 5.4 fails

In the Prerequisites section it states:

Starting with RHEL 5.3, SLES 11 and SLES 10 SP3, Fibre Channel HBAs and mezzanine cards are supported by the in-box drivers (the drivers provided as part of the operating system distributions), and multipath failover is handled by Device Mapper.

Maybe they just recently began to 'enforce' this with the newer RPMs...