HPE EVA Storage

presenting eva snapshots to rhel4

 
CHRIS KRALL
Occasional Contributor

presenting eva snapshots to rhel4

I have an eva-connected proliant running rhel4 and using the hp_qla2x00src-8.01.06-7 drivers. In test. On this box I have an "md" raid device consisting of /dev/sdb1 from an EVA3k and /dev/sdc1 from an EVA5k. I did a makefs3 on the raid device after creating it, then put some data on it.

My desire is to make a snapshot of this device, present it to the host, back it up and then destroy it. (We do this all the time in another apparently "uncool" OS")

So from this linux same host I used sssu_las21 to make a snapshot and presented the virtual device to the linux host. I ran hp_rescan -a but could not see the device. So I rebooted.

Now fdisk -l shows the device as /dev/sdf1. OK. I tried to mount it but was informed the device was already mounted. I did an mdadm --detail and the device was part of a raid set!.

So has anyone experienced this behavior before? Is it feasible to make these types of snapshots in Linux?

2 REPLIES 2
Ivan Ferreira
Honored Contributor

Re: presenting eva snapshots to rhel4

It seems that in this case, you have three complexity problems, the software raid, the lvm, and you are trying to moun on the same server.

See this page:

https://www.data.com.py/foro/viewtopic.php?t=187

Will get you some tips about how to use hardware lvm snapshots on the same server.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Rath Kum
Frequent Advisor

Re: presenting eva snapshots to rhel4

Evan

I cannot open the link which sent
https://www.data.com.py/foro/viewtopic.php?t=187
It page might be expired as its over 2yrs.

My client has the same req. to test the EVA84K Snapshot/clones on the same RHEL5.x . Can u please resend the link or some ref. for mounting source disk and clones on the same host for testing ?

Thanks