HPE EVA Storage

"Volume is Missing" EVA 4k SAN

 
Brett Barton
Occasional Advisor

"Volume is Missing" EVA 4k SAN

Good morning, our school district has an EVA 4k series SAN that consists of two HSV200 controllers as well as 4 disk enclosures containing a mix of FC and FATA drives.

Last week some additional disks were added too quickly to the SAN in the # 4 and 5 enclosures causing a loop interruption. That issue was quickly corrected but we now have an error with two drives in enclosures 1 and 2, which we not touched when the new drives were added.

Currently there are warning signs icon on the "Disk Enclosure 1" and "Disk Enclosure 2." When I expand both enclosures I see 1 disk in each group that has the "red x" icon. IN each enclosure it is Bay 14.

When expanding Bay 14 the Condition/State reported by CV is "Populated (data disk)" with a red X icon. When I click on the Disk Drive tab I receive the error message "Operation Failed! Volume is Missing."

I also managed to locate the same disks in the Disk Group folder, both disks are within the same disk group. The affected disks also show up here as having a red x icon. When I click on the disk under the disk group I get the same message "Operation failed! Volume is Missing."

Once again all this happened after having a loop interruption on enclosure 5, but the two disks having the issues are on enclosure 1 and 2.

The physical drives do not show any error LEDs, nor is there anything interesting in the logs. The VDISKS still show up with green check marks and CV reports "All of your Vdisk data is protected by redundant disk drive storage."

However the messages are still concerning to me. Any pointers would be great.

Thanks!
13 REPLIES 13

Re: "Volume is Missing" EVA 4k SAN

Can you please share the controller event logs and configuration log ?

I work for HPE
Accept or Kudo
Brett Barton
Occasional Advisor

Re: "Volume is Missing" EVA 4k SAN

Thanks for the response, for the controller event log can you use the .idi log file? Also where would I find the configuration log?

I am relatively new to this SAN. My coworker responsible for this SAN recently accepted a new job and can no longer help.

Thanks!

Re: "Volume is Missing" EVA 4k SAN

What is the CV EVA version ?

Attached is the document in order to collect logs.

I work for HPE
Accept or Kudo
Johan Guldmyr
Honored Contributor

Re: "Volume is Missing" EVA 4k SAN

That guide is only for CV 9.x.

Here is the web version of the same guide:

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c01775768

--

To get the logs if you have a lower version, you can look in this thread for the configuration file: http://h30499.www3.hp.com/t5/Storage-Area-Networks-SAN/SSSU-config-capture/m-p/4470195#M39512

-- and yes, it is the .idi file. You can get it from the file system or eva -> events -> controller events -> get log file. (not the parse file) ;)

Brett Barton
Occasional Advisor

Re: "Volume is Missing" EVA 4k SAN

Alright, we are running version 7. So I had to use the SSSU to get the configuration. From the post the second link that Johan provided I ran the script I also did a capture configuration and saved the results into a separate file.

Also I pulled the controller log from CV. Any idea on how far back this log records? The trouble started last week Friday.

I attached a zip file containing 3 logs.

Thanks a lot!
Johan Guldmyr
Honored Contributor

Re: "Volume is Missing" EVA 4k SAN

Brett: I don't have access to the log analyzing tool anymore but can't you sort by date in Command View - to see how far back they go?
Brett Barton
Occasional Advisor

Re: "Volume is Missing" EVA 4k SAN

Well if I go back to the longest "Display Range" I can see all the way back to 2007 which is plenty far.

I just didn't know if the .idi file kept the same date range. I would assume it would.
Johan Guldmyr
Honored Contributor

Re: "Volume is Missing" EVA 4k SAN

It does, it's the same :)

Re: "Volume is Missing" EVA 4k SAN

Thank you for sharing the logs. However config log is not proper.

On 13th May there are hardware errors captured for few drives.

As per my understanding I can suggest you to re-seat the drives at the location enc 1 bay 14, enc 2 bay 14, enc 5 bay 1 and enc 5 bay 2 one by one.

Suggest you to log case with HP because you may have to replace drives.

I work for HPE
Accept or Kudo