HPE EVA Storage

why only 1 lunpath from lun_map?

 
SOLVED
Go to solution
wangjs5
Occasional Contributor

why only 1 lunpath from lun_map?

Experts:

We are using HPUX 11i v3 connected to EMC V-Max with two HBAs through two SAN switches. HBA 1 goes through Switch 1, HBA 2 goes through Switch 2, but they are pointing to the same lun from V-Max.

disk13 and disk14 are the same lun on EMC with same device id/serial number.

Here is the output from "ioscan -kfnNC lunpath":

lunpath 7 0/4/1/0.0x5000097208163d90.0x4001000000000000 eslpt CLAIMED LUN_PATH LUN path for disk13
lunpath 8 0/2/1/0.0x5000097208163dac.0x4001000000000000 eslpt CLAIMED LUN_PATH LUN path for disk14

Here is the output from "scsimgr lun_map -D /dev/rdisk/disk14"

LUN PATH INFORMATION FOR LUN : /dev/rdisk/disk14

Total number of LUN paths = 1
World Wide Identifier(WWID) =

LUN path : lunpath8
Class = lunpath
Instance = 8
Hardware path = 0/2/1/0.0x5000097208163dac.0x4001000000000000
SCSI transport protocol = fibre_channel
State = UNOPEN
Last Open or Close state = ACTIVE

Here is the output from "scsimgr lun_map -D /dev/rdisk/disk13"

LUN PATH INFORMATION FOR LUN : /dev/rdisk/disk13

Total number of LUN paths = 1
World Wide Identifier(WWID) =

LUN path : lunpath7
Class = lunpath
Instance = 7
Hardware path = 0/4/1/0.0x5000097208163d90.0x4001000000000000
SCSI transport protocol = fibre_channel
State = ACTIVE
Last Open or Close state = ACTIVE

Why the OS think disk13 and disk14 are different luns?

I tried "dd" to test disk13 and disk14, and it's only showing traffic from on path each time.

I have a VG created with disk13, when I try to vgextend disk14 into it, it gave me following error:
Verification of unique LVM disk id on each disk in the volume group
vg01 failed.
Following are the sets of disks having identical LVM disk id
/dev/disk/disk13 /dev/disk/disk14

So the LVM knows disk13 and disk14 are the same disk.


Can someone help me on this?

Many thanks,
Jason
5 REPLIES 5
James R. Ferguson
Acclaimed Contributor

Re: why only 1 lunpath from lun_map?

Hi Jason:

From: http://h20000.www2.hp.com/bc/docs/support/SupportManual/c01919369/c01919369.pdf (BSC link updated by admin)

@ page-4:

"Management of multipathed devices is available outside of LVM using the next generation mass storage stack. Agile addressing creates a single persistent DSF for each mass storage device regardless of the number of hardware paths to the disk. The mass storage stack in HP-UX 11iv3 uses that agility to provide transparent multipathing".

Regards!

...JRF...
wangjs5
Occasional Contributor

Re: why only 1 lunpath from lun_map?

Well, I am expecting to see lun path is 2 when I run "scsimgr lun_map -D /dev/rdisk/disk13", and to see traffic going through two paths when I run "dd" against the disk and "sar -L 1 10".

Thanks,
Jason
Turgay Cavdar
Honored Contributor
Solution

Re: why only 1 lunpath from lun_map?

Hi,
I think your initiator settings on the storage side are wrong. Have you set spc-2 flag on the EMC box?
wangjs5
Occasional Contributor

Re: why only 1 lunpath from lun_map?

The spc2 flag is exactly the problem. Thank you very much.

Is enabling the spc2 flag disruptive?

If we turn on the spc2 flag on the EMC FA port, will that negatively impact other HPUX servers running 11.11 and 11.23 connected to the same port?
Turgay Cavdar
Honored Contributor

Re: why only 1 lunpath from lun_map?

As far as i know spc-2 flag is distruptive. If you set on the FA also distruptive for other hosts also. You can set spc-2 flag by using the "set hba_flags" parameter for each WWN. You should check the support matrix for all required flags. It is better to contact with EMC support :))