HPE Ezmeral Software platform

install error

 
Bart_Heungens
Honored Contributor

install error

Hi,

When installing ECP on CentOS7 I get the following error in the log file:

HPE CP Enterprise-Docker release 5.2-3020

Executing INSTALL (PLHA: false NODE: 10.35.14.122)
Logging to /tmp/bds-20210705142128.log
EULA accepted. Continuing.
Printing /etc/hosts
127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
10.35.14.122 ctrl.hpe.local ctrl.hpe.local
bluedata
docker-ce-stable
epel7
Configuring RPM repositories.
Checking to see if running under EC2
Executing /opt/bluedata/bundles/hpe-cp-rhel-release-5.2-3020/scripts/common/yum-action.sh
Loaded plugins: fastestmirror
Cleaning repos: bds-docker-ce-stable bdsepel7 bluedata private
Cleaning up list of fastest mirrors
Other repos take up 66 M of disk space (use --verbose for details)
Installing HPE CP RPMs and dependencies.
Loaded plugins: fastestmirror
Determining fastest mirrors
Failed to exec: yum install -y hpe-cp-mgmt hpe-cp-webui hpe-cp-datatap hpe-cp-config openvswitch ceph-common yum-utils sos python-requests python-argparse python-boto python-requests-kerberos python-urllib3 policycoreutils-python python-dateutil httpd mod_ssl mod_wsgi django cyrus-sasl cyrus-sasl-gssapi cyrus-sasl-md5 krb5-workstation krb5-libs json-c libcurl chrony bind-utils bc lvm2 parted autofs psmisc rpcbind patch curl wget createrepo libcgroup-tools nfs-utils python-iniparse python-ipaddr openssh-clients python-setuptools createrepo openldap-clients libxml2-devel libxslt-devel dnsmasq haproxy socat rsyslog iputils selinux-policy openssl-devel python-cffi python-virtualenv docker-ce-19.03.5 container-storage-setup
[2021-07-05:14-59-18] Executing component scripts for PURPOSE worker, STEP stop

No idea how to go further, installation file is consistent, place enough on machine

Precheck is successfull, no warnings. Internet is OK as well.

What else can I check?

--------------------------------------------------------------------------------
If my post was useful, clik on my KUDOS! "White Star" !
2 REPLIES 2
Dave Olker
HPE Pro

Re: install error

The times I've encountered symptoms like these it was because YUM was not able to find a CentOS mirror server to provide the packages.  Sometimes this is a temporary condition.  Are you able to successfully perform a "yum update -y" on this system outside of the installer?

I work for HPE
Harshkohli
HPE Pro

Re: install error

I agree to what Dave mentioned above. You can give yum update a try and hopefully if yum update works the other script should work and it might be a temporary issue.

I work for HPE