HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

CNA firmware not updated and intelligent provisioning version

Ten_Admin
Occasional Contributor

CNA firmware not updated and intelligent provisioning version

Hello community,

I have the following question. We are in process of migrating from VCEM to OneView. When I make a profile and set a firmware baseline of SPP2015.10.0 the blade is updated by OneView, but the CNA firmware is not updated. I have to boot the blade with the SPP2015.10.0 ISO mounted to get it updated. Is this working as intended?

Another issue I run into is that for some reason not all blades (mix of Gen8 and Gen9) get the same version of intelligent provisioning installed even though they all have the same SPP as firmware baseline. I even get different versions for the same type of blades.

We run the 2.0 version of OneView. I have selected Firmware Only in the profile and I have not selected Force Installation.

Kind regards,

Raymond

 

2 REPLIES
ChrisLynchHPE
Neighborhood Moderator

Re: CNA firmware not updated and intelligent provisioning version

Hello @Ten_Admin, and welcome to the HPE OneView Community Forums.

CNA firmware is supposed to be updated from the SPP Baseline.  Can you please verify the baseline you uploaded has the Linux Smart Component for your CNA?

Also, the SPP does not contain any Intelligent Provisioning (IP) updates.  It is too large (over 950MB) to even think of including within the SPP.  You have three options:

  1. Boot your server into Intelligent Provisioning (F10 during POST), and select the Maintenance option when fully booted.  This will require the server have access to the Internet. We fully know not all customers will have this capability.
  2. Mount the ISO from Virtual Media.  If you have an iLO Advanced license, you can script this via the iLO CLI, RIBCL or REST API.
  3. All HPE OneView Advanced customers are entitled to use Insight Control Server Provisioning (ICSP), which has a build plan to update IP.

The last 2 options require customers to download the ISO from here.  I have linked to the Revision History, so you can dlwonload either 1.62 for Gen8 or 2.40 (just released today) for Gen9's.  1.x is strictly for Gen8's, and 2.x is strictly for Gen9's.

Ten_Admin
Occasional Contributor

Re: CNA firmware not updated and intelligent provisioning version

@ChrisLynchHPE

Thank you for your reply. Some things for me to check and some lessons learned. Thank you for the extensive answer.

Kind regards,

Raymond